Bug 120036 - Numerous run-time usb-related errors
Numerous run-time usb-related errors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-05 09:45 EDT by Phil Schaffner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 14:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzipped tar file with error info and /etc/modprobe.conf (8.99 KB, application/x-compressed-tar)
2004-04-05 09:51 EDT, Phil Schaffner
no flags Details

  None (edit)
Description Phil Schaffner 2004-04-05 09:45:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
Repeated errors "Device not ready.  Make sure there is a disc in the
drive." in dmesg and /var/log/messages.  Kernel is apparently
detecting non-existent usb devices and attempting to access them, for
instance:

Device not ready.  Make sure there is a disc in the drive.
...
Device not ready.  Make sure there is a disc in the drive.
drivers/usb/core/usb.c: registered new driver xpad
drivers/usb/input/xpad.c: X-Box pad driver:v0.0.5
atkbd.c: Keyboard on isa0060/serio0 reports too many keys pressed.
...
atkbd.c: Keyboard on isa0060/serio0 reports too many keys pressed.
usbfs: USBDEVFS_CONTROL failed cmd lsusb dev 2 rqt 128 rq 6 len 256
ret -32
usbfs: USBDEVFS_CONTROL failed cmd lsusb dev 2 rqt 128 rq 6 len 256
ret -32

Also see usb sound-related drivers loaded that are not present on my
system.  Will attach additional info from /var/log/messages, lspci, etc.

Not sure if the keyboard errors have anything to do with the problems.
 I have a PS/2 keyboard that is working normally.


Version-Release number of selected component (if applicable):
kernel-2.6.4-1.305

How reproducible:
Didn't try - but will reboot and check after filing.

Steps to Reproduce:
1. Boot with kernel-2.6.4-1.305
2. Note errors in dmesg, /var/log/messages, ...
3.
    

Actual Results:  Numerous, apparently benign, error messages.

Expected Results:  Many fewer errors.

Additional info:

[root@tabb1 root]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133]
(rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super
South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 16)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]
(rev 40)
00:09.0 Multimedia video controller: Brooktree Corporation Bt878 Video
Capture (rev 02)
00:09.1 Multimedia controller: Brooktree Corporation Bt878 Audio
Capture (rev 02)
00:0b.0 SCSI storage controller: Adaptec AHA-2940U/UW/D / AIC-7881U
00:0d.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
00:0f.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 07)
00:0f.1 Input device controller: Creative Labs SB Live! MIDI/Game Port
(rev 07)
00:13.0 Unknown mass storage controller: Triones Technologies, Inc.
HPT366/368/370/370A/372 (rev 03)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP
(rev 82)
Comment 1 Phil Schaffner 2004-04-05 09:51:48 EDT
Created attachment 99111 [details]
gzipped tar file with error info and /etc/modprobe.conf

Contents of tar file:

[prs@tabb1 prs]$ tar zcvf usb_error_info.tgz *_err /etc/modprobe.conf
lsmod_usb_err
lspci_usb_err
lsusb_usb_err
messages_usb_err
tar: Removing leading `/' from member names
etc/modprobe.conf
Comment 2 Phil Schaffner 2004-04-05 10:17:13 EDT
I have apparently mis-diagnosed "Device not ready.  Make sure there is
a disc in the drive." error.  On closer inspection it seems to be
CD-ROM related.  Other USB device messages such as X-box xpad, midi,
and too many keys pressed are new and still seem strange.
Comment 3 Pete Zaitcev 2004-08-10 15:40:50 EDT
How is FC2 final? Or 2.6.7-1.494.2.2 (update)?

Note You need to log in before you can comment on or make changes to this bug.