Bug 120046 - fdisk: can't create file system ext2 after creating extended partition
fdisk: can't create file system ext2 after creating extended partition
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
1
athlon Linux
low Severity medium
: ---
: ---
Assigned To: Elliot Lee
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-05 10:59 EDT by Dechico Marc
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-23 10:35:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dechico Marc 2004-04-05 10:59:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:


fdisk:
when trying to add a fourth extended partition on my hd after saving
the table with option w.
get message: 
---------------------------------------------------------------------
WARNING: Re-reading the partition table failed with error 16: Device
or resource busy.
The kernel still uses the old table.
The new table will be used at the next reboot.
Syncing disks.
-----------------------------------------------------------------

I tryed to create the file system with mke2fs after re-booting but it
refused with message: Device size reported to be zero.  

Version-Release number of selected component (if applicable):
util-linux-2.11y-29

How reproducible:
Always

Steps to Reproduce:
1. /sbin/fdisk 
--------------------------------------------------------------------
Command (m for help): p
 Disk /dev/hda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        19    152586   83  Linux
/dev/hda2            20      1931  15358140   83  Linux
/dev/hda3          1932      2058   1020127+  82  Linux swap
 
Command (m for help): n
Command action
   e   extended
   p   primary partition (1-4)
e
Selected partition 4
First cylinder (2059-10011, default 2059):
Using default value 2059
Last cylinder or +size or +sizeM or +sizeK (2059-10011, default
10011): +3000M
 
Command (m for help): w
The partition table has been altered!
 
Calling ioctl() to re-read partition table.
WARNING: Re-reading the partition table failed with error 16: Device
or resource busy.
The kernel still uses the old table.
The new table will be used at the next reboot.
Syncing disks.
 
2.after booting 
---------------------------------------------------------------------
Command (m for help): p
 
Disk /dev/hda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        19    152586   83  Linux
/dev/hda2            20      1931  15358140   83  Linux
/dev/hda3          1932      2058   1020127+  82  Linux swap
/dev/hda4          2059      2424   2939895    5  Extended
 
3.
----------------------------------------------------------------
[root@asr dechicom]# /sbin/mke2fs -c  -b4096 -N500 /dev/hda4
mke2fs 1.34 (25-Jul-2003)
mke2fs: Device size reported to be zero.  Invalid partition specified,
or  partition table wasn't reread after running fdisk, due to
a modified partition being busy and in use.  You may need to reboot
to re-read your partition table.
 
Actual Results:  Not possible to create the file systeme even if
re-booting

Expected Results:  to create the file system after creating the partition

Additional info:

Asrock K7S8X R3.0 with AMD Athlon XP2500+  hd ExcelStor 80G
Comment 1 Dechico Marc 2004-04-07 08:29:16 EDT
Ok! wasn't really a bug. I just didn't understand how extended
partition  works. But I would have lost less time with a clear message.

Note You need to log in before you can comment on or make changes to this bug.