Bug 1200479 - "users" allows setting/clearing fingerprint without authentication
Summary: "users" allows setting/clearing fingerprint without authentication
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-10 16:09 UTC by Jeremy Fitzhardinge
Modified: 2015-03-10 16:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-10 16:54:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Jeremy Fitzhardinge 2015-03-10 16:09:08 UTC
Description of problem:
The "users" area of settings allows fingerprint data to be set/cleared without authentication

Version-Release number of selected component (if applicable):
control-center-3.14.2-2.fc21.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Walk up to someone's session
2. Open Settings->Users
3. Set your fingerprint to log in

Actual results:
Anyone can override existing fingerprint login with their own

Expected results:
It should require the "users" panel to be unlocked before manipulating fingerprint settings.

Additional info:
Looks like this was previously reported as #827968 but was closed unfixed.

Comment 1 Bastien Nocera 2015-03-10 16:54:31 UTC
Already been filed upstream:
https://bugzilla.freedesktop.org/show_bug.cgi?id=89407


Note You need to log in before you can comment on or make changes to this bug.