Bug 1200662 - Passenger Module loaded twice
Summary: Passenger Module loaded twice
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.0.8
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Ondřej Pražák
QA Contact: Kedar Bidarkar
URL: https://github.com/puppetlabs/puppetl...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-11 06:12 UTC by jnikolak
Modified: 2019-09-26 14:34 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-14 16:26:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
httpd restart (50.04 KB, image/png)
2016-03-16 12:01 UTC, Ondřej Pražák
no flags Details
passenger.conf (95.89 KB, image/png)
2016-03-16 12:03 UTC, Ondřej Pražák
no flags Details

Description jnikolak 2015-03-11 06:12:42 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


#### start httpd #####

[root@jniksat6 ~]# service httpd start
Starting httpd: [Wed Mar 11 05:26:22 2015] [warn] module passenger_module is already loaded, skipping
                                                           [FAILED]
##### comment out passenger.load ########

sed 's/Load/#Load/g' /etc/httpd/conf.d/passenger.load | tee /etc/httpd/conf.d/passenger.load


check passenger.conf
sed 's/Load/#Load/g' /etc/httpd/conf.d/passenger.load | tee /etc/httpd/conf.d/passenger.load


#### Then restart httpd ####
Issue is gone

Comment 1 RHEL Program Management 2015-03-11 06:13:10 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Ondřej Pražák 2016-03-16 12:01:24 UTC
Created attachment 1136987 [details]
httpd restart

This issue is not present in 6.2.0-4.beta.

Comment 4 Ondřej Pražák 2016-03-16 12:03:36 UTC
Created attachment 1136988 [details]
passenger.conf

There is also no /etc/httpd/conf.d/passenger.load file, only /etc/httpd/conf.d/passenger.conf, which does not load any modules.

Comment 6 Kedar Bidarkar 2016-04-12 18:52:52 UTC
I see this below from sat62-snap7.1 on RHEL6 

conf.d]# grep -R passenger_module *
passenger.conf:LoadModule passenger_module modules/mod_passenger.so
zpassenger.load:LoadModule passenger_module modules/mod_passenger.so

I do see multiple similar entries, so Is this an issue?

Comment 7 Ondřej Pražák 2016-04-14 10:53:54 UTC
I managed to reproduce today on RHEL6, RHEL7 is unaffected by this. It seems to be a present issue on RHEL6, I will work on a fix.

Comment 8 Kedar Bidarkar 2016-04-15 15:35:03 UTC
As this is still an issue will be moving this to ASSIGNED state.

Comment 9 Ondřej Pražák 2016-04-18 15:52:34 UTC
Created redmine issue http://projects.theforeman.org/issues/14687 from this bug

Comment 10 Bryan Kearney 2016-04-18 16:06:18 UTC
Upstream bug component is Installer

Comment 13 Stephen Benjamin 2016-10-14 16:26:57 UTC
This was fixed in puppetlabs-apache: https://github.com/puppetlabs/puppetlabs-apache/pull/1345


Note You need to log in before you can comment on or make changes to this bug.