Bug 1200774 - openstack-nova-compute won't install on RHEL 7.1
Summary: openstack-nova-compute won't install on RHEL 7.1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 7.0 (Kilo)
Assignee: Lon Hohberger
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-11 11:25 UTC by Marko Myllynen
Modified: 2019-09-09 15:29 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-18 19:38:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
yum log (41.19 KB, text/plain)
2015-03-12 15:51 UTC, Marko Myllynen
no flags Details

Description Marko Myllynen 2015-03-11 11:25:27 UTC
Description of problem:
openstack-nova-compute fails to install on RHEL 7 with all the latest updates installed (=7.1.z), it has dependencies to older krb5-libs and procps-ng. If one downgrades krb5-libs and procps-ng then openstack-nova-compute installs ok.

Version-Release number of selected component (if applicable):
openstack-nova-compute-2014.2.2-2.el7ost.noarch
krb5-libs-1.11.3-49.el7 / krb5-libs-1.12.2-14.el7
procps-ng-3.3.9-6.el7 / procps-ng-3.3.10-3.el7

Comment 3 Alan Pevec 2015-03-12 11:09:38 UTC
What are steps to reproduce? Please provide output of failing yum install command.

Comment 4 Alan Pevec 2015-03-12 11:22:05 UTC
I cannot reproduce, with
krb5-libs-1.12.2-14.el7.x86_64
procps-ng-3.3.10-3.el7.x86_64
installed, yum install openstack-nova-compute worked fine on a RHEL 7.1 machine with rhel-7-server-rpms CDN repo enabled.
Please also provide your yum repolist.

Comment 5 Marko Myllynen 2015-03-12 15:50:55 UTC
There was a bit of confusion about the versions as I hit this on both OSP 5 and OSP 6, sorry about that, let's deal with OSP 5 here as it's the only one with real issue.

First, repository configuration is the key here, in my test it is according to:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html/Getting_Started_Guide/chap-Product_Requirements.html#sect-Configure_Software_Repositories

Which states that rhel-7-server-openstack-5.0-rpms should have priority set to 1.

openstack-nova-compute requires python-libguestfs which is available in all the required repositories as follows:

rhel-x86_64-server-7: python-libguestfs-1.28.1-1.18.el7.x86_64.rpm
rhel-x86_64-server-7-openstack-5.0-rpms: python-libguestfs-1.22.6-22.el7.x86_64.rpm
rhel-x86_64-server-7-openstack-6.0-rpms: python-libguestfs-1.22.6-22.el7.x86_64.rpm
rhel-x86_64-server-optional-7: python-libguestfs-1.22.6-22.el7.x86_64.rpm

python-libguestfs in turn requires libguestfs which in turn has dependendies to krb5-libs and procps-ng.

When trying to install with the repo priority set, the older version python-libguestfs-1.22.6-22.el7 gets selected from rhel-x86_64-server-7-openstack-5.0-rpms (as expected) but that will pull in libguestfs-1.22.6-22.el7 which then triggers the dependency issues. However, if removing the special priority from the rhel-x86_64-server-7-openstack-5.0-rpms repo then python-libguestfs-1.28.1-1.18.el7 from rhel-x86_64-server-7 will be picked up instead and the installation completes nicely.

For OSP 6 priority setting is not documented so on that front all looks to be ok (so the issue was a local one as I used the inherited repository priority from OSP 5). But for OSP 5 the repository configuration as documented leads currently to this dependency issue.

I'll attach a yum debug output from a RHEL 7.1 node when trying to install OSP 5 openstack-nova-compute there, it should illustrate the issue.

Please let me know if you need more information or if there could be another local issue.

Thanks.

Comment 6 Marko Myllynen 2015-03-12 15:51:23 UTC
Created attachment 1001039 [details]
yum log

Comment 7 Iain Geddes 2015-03-22 21:51:59 UTC
I also appeared to have stumbled across the same issue for OS6 on RHEL7.1.

Server completely clean minimal install from RHEL 7.1 ISO then went through basic steps as initially defined by the Getting Started Guide:

https://access.redhat.com/products/red-hat-enterprise-linux-openstack-platform/get-started


subscription-manager register 
subscription-manager attach --pool=[RHEL OpenStack Platform]
yum update -y
subscription-manager repos --disable=*
subscription-manager repos --enable=rhel-7-server-rpms
subscription-manager repos --enable=rhel-7-server-optional-rpms
subscription-manager repos --enable=rhel-7-server-openstack-6.0-rpms
yum install -y yum-plugin-priorities yum-utils
yum-config-manager --setopt="rhel-7-server-openstack-6.0-rpms.priority=1" --enable rhel-7-server-openstack-6.0-rpms
yum update -y
yum install -y ntp ntpdate wget openstack-selinux openstack-utils
systemctl disable NetworkManager
cd /etc
openstack-config --set sysctl.conf '' net.ipv4.ip_forward 1
openstack-config --set sysctl.conf '' net.ipv4.conf.all.rp_filter 0
openstack-config --set sysctl.conf '' net.ipv4.conf.default.rp_filter 0
sysctl -p


#Confirm firewalld disabled and no iptables rules applied
iptables -L
systemctl stop firewalld && systemctl disable firewalld
ntpdate 0.us.pool.ntp.org
systemctl enable ntpd && systemctl start ntpd

reboot

yum install -y openstack-nova-compute

Yum terminates with the error:
Error: Package: 1:libguestfs-1.22.6-22.el7.x86_64 (rhel-7-server-rpms)
           Requires: libkadm5srv_mit.so.8()(64bit)
           Available: krb5-libs-1.11.3-49.el7.x86_64 (rhel-7-server-rpms)
               libkadm5srv_mit.so.8()(64bit)
           Installed: krb5-libs-1.12.2-14.el7.x86_64 (@anaconda/7.1)
              ~libkadm5srv_mit.so.9()(64bit)
Error: Package: 1:libguestfs-1.22.6-22.el7.x86_64 (rhel-7-server-rpms)
           Requires: libprocps.so.3()(64bit)
           Available: procps-ng-3.3.9-6.el7.x86_64 (rhel-7-server-rpms)
               libprocps.so.3()(64bit)
           Installed: procps-ng-3.3.10-3.el7.x86_64 (@anaconda/7.1)
              ~libprocps.so.4()(64bit)

A successful reinstall of these packages simply changes @anaconda/7.1 to rhel-7-server-rpms. As seen by Marko, removing the priority flag allows the install to complete successfully.

Comment 11 Lon Hohberger 2015-08-18 19:38:07 UTC
This was resolved some time ago when we resynced libguestfs.  This issue was specifically caused by a lag between 7.1 GA and our update of libguestfs in the OSP 6 channel.


Note You need to log in before you can comment on or make changes to this bug.