Bug 120097 - bugzilla URLs in email are incorrect - "Your Bugzilla buglist needs attention."
bugzilla URLs in email are incorrect - "Your Bugzilla buglist needs attention."
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-05 19:11 EDT by Karsten Wade
Modified: 2007-04-18 13:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 03:35:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2004-04-05 19:11:36 EDT
Description of problem:

I received a (helpful) email from bugzilla@redhat.com today reminding
me about some stagnant bugs in my list. The URLs in the email are
incorrect.  There is a substitution of 'bugzilla-devel-2.17' for
'bugzilla' in the URL.

##begin quote

The following bugs are in an open state, assigned to you, and stagnant 

Bug, Priority, Severity, Description, Last Touched
--------------------------------------------------
104265, normal, normal, WebSphere 5 notes for Documentation, 2003-11-04
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=104265
109825, normal, normal, Troika errata metablocker bug., 2003-12-10
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=109825
109829, normal, normal, Installation Guide Troika errata blocker bug.,
2003-11-14
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=109829
110043, normal, normal, SEL: SELinux Application Developer Guide meta
blocker/tracker., 2004-01-13
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=110043
110044, normal, normal, SEL: SELinux Policy Writing Guide meta
blocker/tracker., 2004-01-13
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=110044

## end

How reproducible:

Very, from this email.

Steps to Reproduce:
1. Open email
2. Click on link
3. Notice incorrect URL, fix, and get to real link
  
etc. skipped for being uneccessary.
Comment 1 Karsten Wade 2004-04-05 19:13:24 EDT
Here is the full mail message, just in case it helps:

## begin message

Return-Path: <root@beta.redhat.com>
Received: from pobox.corp.redhat.com ([unix socket]) by
pobox.corp.redhat.com (Cyrus v2.1.12) with LMTP; Mon, 05 Apr 2004
18:17:11 -0400
X-Sieve: CMU Sieve 2.2
Received: from int-mx1.corp.redhat.com (int-mx1.corp.redhat.com
[172.16.52.254]) by pobox.corp.redhat.com (8.12.8/8.12.8) with ESMTP
id i35MHBnM012786 for <kwade@pobox.corp.redhat.com>; Mon, 5 Apr 2004
18:17:11 -0400
Received: from mx1.redhat.com (mx1.redhat.com [172.16.48.31]) by
int-mx1.corp.redhat.com (8.11.6/8.11.6) with SMTP id i35MHBj25885 for
<kwade@redhat.com>; Mon, 5 Apr 2004 18:17:11 -0400
Received: from www.beta.redhat.com (beta.redhat.com [172.16.48.203])
by mx1.redhat.com (8.12.10/8.12.10) with ESMTP id i35MHB5D015165 for
<kwade@redhat.com>; Mon, 5 Apr 2004 18:17:11 -0400
Received: from www.beta.redhat.com (localhost.localdomain [127.0.0.1])
by www.beta.redhat.com (8.12.10/8.12.10) with ESMTP id i35MBTpR003170
for <kwade@redhat.com>; Mon, 5 Apr 2004 18:11:29 -0400
Received: (from root@localhost) by www.beta.redhat.com
(8.12.10/8.12.10/Submit) id i35MBTcC003168; Mon, 5 Apr 2004 18:11:29 -0400
Date: Mon, 5 Apr 2004 18:11:29 -0400
Message-Id: <200404052211.i35MBTcC003168@www.beta.redhat.com>
From: bugzilla@redhat.com
To: kwade@redhat.com
Subject: Your Bugzilla buglist needs attention.
Content-type: text/plain; charset=utf-8
X-Loop: bugzilla@redhat.com
X-BeenThere: bugzilla@redhat.com 
X-RedHat-Spam-Score: -99.715 
X-Evolution-Source: imap://kwade@pobox.corp.redhat.com/	
[This e-mail has been automatically generated.]
                                                                                                                                           

You have one or more bugs assigned to you in Bugzilla 
(https://bugzilla.redhat.com/bugzilla-devel-2.17/) that require attention.
                                                                                                                                           

(1) You decide this bug is really quick to deal with (like, it's NOTABUG),
    and so you get rid of it immediately.
(2) You decide the bug doesn't belong to you, and you reassign it to
someone
    else.  (Hint: if you don't know who to reassign it to, make sure that
    the Component field seems reasonable, and then use the "Reassign
bug to
    owner of selected component" option.)
(3) You decide the bug belongs to you, but you can't solve it this moment.
    Just use the "Accept bug" (ASSIGNED) command.
                                                                                                                                           

To get a list of all NEW bugs, you can use this URL (bookmark it if
you like!):
https://bugzilla.redhat.com/bugzilla-devel-2.17/buglist.cgi?bug_status=NEW&assigned_to=kwade@redhat.com
                                                                                                                                           

Or, you can use the general query page, at
https://bugzilla.redhat.com/bugzilla-devel-2.17/query.cgi

The following bugs are in a NEW state and owned by you.
They should be accepted or reassigned to get them off this list.

Bug, Priority, Severity,  Description, Created
----------------------------------------------

The following bugs are in an open state, assigned to you, and stagnant 

Bug, Priority, Severity, Description, Last Touched
--------------------------------------------------
104265, normal, normal, WebSphere 5 notes for Documentation, 2003-11-04
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=104265
109825, normal, normal, Troika errata metablocker bug., 2003-12-10
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=109825
109829, normal, normal, Installation Guide Troika errata blocker bug.,
2003-11-14
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=109829
110043, normal, normal, SEL: SELinux Application Developer Guide meta
blocker/tracker., 2004-01-13
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=110043
110044, normal, normal, SEL: SELinux Policy Writing Guide meta
blocker/tracker., 2004-01-13
https://bugzilla.redhat.com/bugzilla-devel-2.17/show_bug.cgi?id=110044

## 30
Comment 2 David Lawrence 2004-04-06 03:35:14 EDT
Yeah. that was a test email that I sent out that was using a
development tree. The production code will automatically have the
correct url.

Not sure when this will be in effect though since there is still some
debate whether this will annoy developers more than it will help. 

I will start a thread on os-devel list asking for people's opinions.


Note You need to log in before you can comment on or make changes to this bug.