Bug 120099 - orinoco_cs information frame lost -- syslog activity makes system unresponsive
orinoco_cs information frame lost -- syslog activity makes system unresponsive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-05 19:31 EDT by Jost Diederichs
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.5-1.322
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 10:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jost Diederichs 2004-04-05 19:31:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
Gecko/20040316

Description of problem:
In late kernel versions (2.6.4-1.305 probably all the way back to
2.6.3) the orinoco wireless module appears to have become unstable. 
There are several symptoms: 
 - most common is that it will flood syslog with "kernel: eth0:
Information frame lost." messages, so that the laptop (toshiba
Satellite Pro 4300) will be rendered practically unresponsive.
Manually pulling the card (Netgear MA401) typically lets the computer
recover. (see debug output below)
 - total computer freezes to where the bios won't even respond to the
backlight switch (I guess this is due to the PCMCIA/wireless sytem)
 - temporary losses of association ( I have no other debug info on this )

This wireless card used with the orinoco driver has in the past been
rock solid. 



Version-Release number of selected component (if applicable):
kernel-2.6.4-1.305 (and a few earlier)

How reproducible:
Always

Steps to Reproduce:
1. High network traffic especially across a mounted nfs file system


Additional info:

Apr  4 20:34:07 localhost kernel: eth0: Information frame lost.
Apr  4 20:34:27 localhost last message repeated 1606 times
Apr  4 20:34:27 localhost kernel: spurious 8259A interrupt: IRQ7.
Apr  4 20:34:27 localhost kernel: eth0: Information frame lost.
Apr  4 20:34:57 localhost last message repeated 4738 times
Apr  4 20:35:16 localhost last message repeated 2911 times
Apr  4 20:35:17 localhost kernel: hermes @ IO 0x100: Timeout waiting
for command completion.
Apr  4 20:35:17 localhost kernel: eth0: Error -110 transmitting packet
Apr  4 20:35:17 localhost kernel: hermes @ IO 0x100: Timeout waiting
for command completion.
Apr  4 20:35:17 localhost kernel: eth0: Error -110 transmitting packet
Apr  4 20:35:17 localhost kernel: hermes @ IO 0x100: Error -16 issuing
command.
Apr  4 20:35:17 localhost kernel: eth0: Error -16 transmitting packet
Apr  4 20:35:17 localhost kernel: hermes @ IO 0x100: Error -16 issuing
command.
Apr  4 20:35:17 localhost kernel: eth0: Error -16 transmitting packet
Apr  4 20:35:17 localhost kernel: hermes @ IO 0x100: Error -16 issuing
command.
Apr  4 20:35:17 localhost kernel: eth0: Error -16 transmitting packet
Apr  4 20:35:17 localhost kernel: hermes @ IO 0x100: Error -16 issuing
command.
Apr  4 20:35:17 localhost kernel: eth0: Error -16 transmitting packet
Apr  4 20:35:17 localhost kernel: hermes @ IO 0x100: Error -16 issuing
command.
Comment 1 Johan Vromans 2004-11-18 12:36:37 EST
I have the same problems, making wireless use of my notebook almost
impossible. I'm using an ASUS WL-100 card on a Toshiba 7020CT, with
Fedora Core 2 (+updates) and kernel 2.6.8-1.521.

Note You need to log in before you can comment on or make changes to this bug.