Bug 120110 - screen cannot create temporary files
screen cannot create temporary files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
triage|leonardjo|closed|rawhide
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-05 21:15 EDT by Albert Strasheim
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.9.2-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-11 04:32:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2004-04-05 21:15:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
screen fails to start (when run by a normal user) because it cannot
create temporary files. The following message is displayed:

Cannot make directory '/tmp/uscreens': Permission denied

The following audit messages appear in /var/log/messages:

Apr  6 03:18:06 asok kernel: audit(1081214286.221:0): avc:  denied  {
search } for  pid=3903 exe=/usr/bin/screen name=tmp dev=hda5
ino=1048577 scontext=user_u:user_r:user_screen_t
tcontext=system_u:object_r:tmp_t tclass=dir
Apr  6 03:19:16 asok kernel: audit(1081214356.596:0): avc:  denied  {
search } for  pid=3906 exe=/usr/bin/screen name=tmp dev=hda5
ino=1048577 scontext=user_u:user_r:user_screen_t
tcontext=system_u:object_r:tmp_t tclass=dir

Version-Release number of selected component (if applicable):
screen-4.0.1-4 policy-1.9.2-9

How reproducible:
Always

Steps to Reproduce:
1. Start screen as a normal user

    

Actual Results:  screen fails to start because it cannot make
temporary files

Expected Results:  screen should start without problems

Additional info:
Comment 1 Daniel Walsh 2004-04-05 22:05:27 EDT
Try this with the latest policy 1.9.2-12.

Dan

Note You need to log in before you can comment on or make changes to this bug.