Bug 120120 - ntpd: Synchronizing with time server fails on boot
Summary: ntpd: Synchronizing with time server fails on boot
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-06 07:35 UTC by Michael J. Kofler
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 10:24:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ntp.conf file (230 bytes, text/plain)
2004-05-07 22:12 UTC, Darin May
no flags Details
step-tickers file (49 bytes, text/plain)
2004-05-07 22:13 UTC, Darin May
no flags Details

Description Michael J. Kofler 2004-04-06 07:35:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
ntpd: Synchronizing with time server fails on boot. It seems to try to connect to the server before ntpd starts up, which would explain why it fails (ntpd starts successfully as the next service after synchronizing fails). ntpd appears to successfully synchronize with the time.nist.gov server when running system-config-date from gnome.

Version-Release number of selected component (if applicable):
ntp-4.1.2-0.rc1.2
ntp-4.2.0-7
(both appear to be installed after upgrade fromn RH9

How reproducible:
Always

Steps to Reproduce:
1. turn on computer and watch for services starting
2. 
3.
    

Actual Results:  ntpd: Synchronizing with time server fails on boot

Expected Results:  ntpd: Synchronizing with time server OK

Additional info:

Comment 1 Harald Hoyer 2004-04-06 08:37:29 UTC
deinstall the old package
# rpm -e ntp-4.1.2-0.rc1.2

which timeservers do you use?

what does
# ntpdate -v <timeserver>
output?

Comment 2 Michael J. Kofler 2004-04-06 19:53:43 UTC
Using timeserver time.nist.gov 
 
[root@endor mkofler]# /usr/sbin/ntpdate -v time.nist.gov 
 6 Apr 15:57:15 ntpdate[4657]: ntpdate 4.2.0@1.1161-r Thu Mar 11 
11:46:40 EST 2004 (1) 
Looking for host time.nist.gov and service ntp 
host found : time.nist.gov 
 6 Apr 15:57:15 ntpdate[4657]: the NTP socket is in use, exiting 
[1]+  Done                    find / -name ntpdate 
 
Thanks, 
-M 

Comment 3 Harald Hoyer 2004-04-07 08:20:41 UTC
ok... better use
# /usr/sbin/ntpdate -d -u -v time.nist.gov 

Comment 4 Michael J. Kofler 2004-04-07 16:01:52 UTC
Looks like it worked (outout below). It seemed to work using the GUI 
system-config-date as well- the only problem was that on boot it was 
trying to synchronize with the time server before ntpd was loaded. 
where can i edit the processes that load on boot to switch the order? 
Thanks! 
 
[root@endor mkofler]# /usr/sbin/ntpdate -d -u -v time.nist.gov 
 7 Apr 12:04:52 ntpdate[7687]: ntpdate 4.2.0@1.1161-r Thu Mar 11 
11:46:40 EST 2004 (1) 
Looking for host time.nist.gov and service ntp 
host found : time.nist.gov 
transmit(192.43.244.18) 
receive(192.43.244.18) 
transmit(192.43.244.18) 
receive(192.43.244.18) 
transmit(192.43.244.18) 
receive(192.43.244.18) 
transmit(192.43.244.18) 
receive(192.43.244.18) 
transmit(192.43.244.18) 
server 192.43.244.18, port 123 
stratum 1, precision -18, leap 00, trust 000 
refid [ACTS], delay 0.13550, dispersion 0.00230 
transmitted 4, in filter 4 
reference time:    c41ea495.9d3f9e7b  Wed, Apr  7 2004 12:02:29.614 
originate timestamp: c41ea4c5.e47ad080  Wed, Apr  7 2004 12:03:17.892 
transmit timestamp:  c41ea524.cf19b4dc  Wed, Apr  7 2004 12:04:52.808 
filter delay:  0.13647  0.16609  0.13550  0.13672 
         0.00000  0.00000  0.00000  0.00000 
filter offset: -94.9735 -94.9581 -94.9734 -94.9720 
         0.000000 0.000000 0.000000 0.000000 
delay 0.13550, dispersion 0.00230 
offset -94.973414 
  
 7 Apr 12:04:52 ntpdate[7687]: step time server 192.43.244.18 offset 
-94.973414 sec 
 

Comment 5 Darin May 2004-04-25 00:10:02 UTC
Seems the /etc/rc3.d/S58ntpd script has a bug.

Comment 6 Harald Hoyer 2004-05-05 12:24:43 UTC
please attach
/etc/ntp/step-tickers
and
/etc/ntp.conf


Comment 7 Darin May 2004-05-07 22:12:51 UTC
Created attachment 100100 [details]
ntp.conf file

Comment 8 Darin May 2004-05-07 22:13:36 UTC
Created attachment 100101 [details]
step-tickers file

Comment 9 Darin May 2004-05-14 22:20:43 UTC
Aha.  Afer reinstalling test3 from scrath it works.  What I noticed is
that there is now a proper ACL in the firewall rule to allow this to work.

Perhaps non-working configs are suffering from a blocked NTP port.


Note You need to log in before you can comment on or make changes to this bug.