Bug 120121 - Booting with multiple disks with multiple linux installations confuses the mount-by-label logic
Booting with multiple disks with multiple linux installations confuses the mo...
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-04-06 03:38 EDT by Brian "netdragon" Bober
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-04-16 13:55:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian "netdragon" Bober 2004-04-06 03:38:11 EDT
Description of problem:
When I attach a hdc and hdd, both 100GB+ size drives to the secondary
ribbon, I get errors about /var/log/dmesg, etc, not existing... Its
almost as if its trying to read the data off those drives even though
I'm booting off hda. When I disconnect them from the ribbon, it boots
without problems. Both drives have root partitions, but I'm booting
off of drive hda, not hdc or hdd.

Version-Release number of selected component (if applicable):

Additional info:

I have all the latest updates.
I can't show the log of the error because it also says it can't find
/var/log/messages or something (Can't remember exactly which)
Comment 1 Brian "netdragon" Bober 2004-04-06 04:33:36 EDT
I tried the best to reconstruct the error messages but they move so 
fast and I can't pause.

When it boots up with that graphical scroll thing and you click "Show 
Details...", this is what it does (#@$#@$@$@ represents ASCII 
characters 128-255, i.e. garbled nonsense)

INIT: Entering runlevel: 5
Entering non-interactive startup
Applying IA32 microcode [OK]
Starting systat: Calling the system activity data collector (sadc) 
@#$#@$#@ $#@ #@ $[OK]
3@$#$  $#@$ #@$#@$ @[FAILED]
#$#@$#@$#@# $#@#@$#@$#@#@@$#@$ [OK]
on and on

Ending with a message: "Server Authorization directory [snip] does 
not exist. [snip]"

If I press CTRL-ALT-BACKSPACE, I can log into the prompt

df shows me only the root partition /dev/hda2, but i have more... Its 
missing /var, /home, /data, /boot

What's even more funky is that when I mounted them, the X windows 
login thing worked...

Furthermore, I was able to mount hdc3 and hdd3.

But, if I reboot, its messed up again. I guess for now I can throw 
the mounting into a script and init 3 :-(
Comment 2 Brian "netdragon" Bober 2004-04-06 05:18:16 EDT
I created a script, made it called from /etc/rc.d/rc.sysinit, and now
everything mounts properly, and I can boot into Gnome.

I get this error before I see the message "Mounting fu!". That's
probably the piece of gold right there:
Mounting local filesystems: mount: LABEL=/boot duplicate - not mounted

Now what bugs me is these messages and messages like it are not
logged, so I had to place a "sleep 40" in my script and write it down
by hand. Why aren't these messages (the [ OK ], [ FAILED ] messages)

Here is /root/mount.sh:

echo Mounting fu!
mount /dev/hdc3 /mnt/hdc
mount /dev/hdd3 /mnt/hdd
mount /dev/hda1 /boot
mount /dev/hda3 /data
mount /dev/hda5 /var
mount /dev/hda6 /home
echo Mounting fu done!

Here is the /etc/rc.d/rc.sysinit with the changes:

# Mount all other filesystems (except for NFS and /proc, which is already
# mounted). Contrary to standard usage,
# filesystems are NOT unmounted in single user mode.
action $"Mounting local filesystems: " mount -a -t
nonfs,nfs4,smbfs,ncpfs -O no_netdev

#temp netdragon

# Start the graphical boot, if necessary and not done yet.
if fgrep rhgb /proc/cmdline > /dev/null 2>&1 && [ "$RHGB_STARTED" -eq
0 -a "$BOOTUP" = "color" -a
Comment 3 Brian "netdragon" Bober 2004-04-06 05:19:17 EDT
Notice that I just provided an excerpt of /etc/rc.d/rc.sysinit.
Comment 4 Arjan van de Ven 2004-04-06 05:22:46 EDT
Mounting local filesystems: mount: LABEL=/boot duplicate - not mounted

looks like the disk you added also has a linux installation which
confuses the mount-by-label logics and things go really unhappy from
then onwards...
Comment 5 Brian "netdragon" Bober 2004-04-06 05:29:34 EDT
Yes, hdd and hdc both have a root "/" partition with /home etc on the
same partition, while hda has a root "/" partition with /home, etc in
different partitions. Thing is, Grub is installed on hda, and its
booting into hda. hdd is an old redhat 7.2 disk, and hdc is an old rh9
Comment 6 Brian "netdragon" Bober 2004-04-13 18:40:30 EDT
Re-summarizing bug with the information given from comment #4
Comment 7 Arjan van de Ven 2004-04-16 04:56:05 EDT
I'm not sure we can do anything about this realistically...
Comment 8 Jeremy Katz 2004-04-16 13:55:48 EDT
If you move new disks in, you need to ensure that they don't have
conflicting labels.  This is the downside of mount-by-label (which
fixes the case of being able to move drives within a box without problems)
Comment 9 Brian "netdragon" Bober 2004-04-23 18:31:04 EDT
Relabeling the drives did fix the problem. 

There is no way to make it so that if it has a conflict it defaults 
to the hard drive it booted on or asks the user (probably the best 

Note You need to log in before you can comment on or make changes to this bug.