Bug 120123 - m4 problem with dhcp file contexts
Summary: m4 problem with dhcp file contexts
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-06 08:20 UTC by Tim Waugh
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 22:14:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dhcp-patch (942 bytes, patch)
2004-04-06 08:21 UTC, Tim Waugh
no flags Details | Diff

Description Tim Waugh 2004-04-06 08:20:20 UTC
Description of problem:
/var/lib/dhcp/dhcp.leases is not getting the right file context.

Version-Release number of selected component (if applicable):
policy-1.9.2-12

How reproducible:
100%

Patch below.

Comment 1 Tim Waugh 2004-04-06 08:21:14 UTC
Created attachment 99131 [details]
dhcp-patch

Comment 2 Daniel Walsh 2004-04-06 10:42:05 UTC
Not sure why this breaks but added to policy-1.9.2-13

Dan

Comment 3 Tim Waugh 2004-04-06 12:08:02 UTC
It breaks because dhcpc.te is processed before dhcpd.te, and by that
stage 'dhcp' is an m4 macro.  But the regexp for dhcp.leases looks like:

/var/lib(64)?/dhcp(3)?/dhcp\.leases.*

and gets processed to:

/var/lib(64)?/?/dhcp\.leases.*

..which obviously isn't what we want.

There might be more occurrences of this problem; this is the first
I've found though.


Note You need to log in before you can comment on or make changes to this bug.