Bug 12013 - anaconda incorrectly creates XF86Config-4
Summary: anaconda incorrectly creates XF86Config-4
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
: 12126 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-09 05:31 UTC by Jeremy Katz
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-18 18:21:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2000-06-09 05:31:09 UTC
Using a Matrox Mystique.  X Configuration, Custom config.  Select only 16
bpp 1024x768 as the resolution to support after having the monitor and
video card correctly selected.  /etc/X11/XF86Config-4 will then have a
screen section that does not allow X to start as there isn't a
configuration for 8bpp, and a DefaultColorDepth directive is not set inside
the Screen section.  Fix should be similar to what is used to set
DefaultColorDepth in Version3Config()

Comment 1 Hans de Goede 2000-06-12 18:06:13 UTC
I have seen this on multiple cards and install too, if you don't select any 8bpp
modes you get an invalid XF86Conifg, if DefaultColorDepth is omitted XF 40
doesn't user the first display section (as XF 33 does), but assumes
DefaultColorDepth is 8 if there is no 8 bpp section XF 40 exits with an error.


Comment 2 Jeremy Katz 2000-06-13 00:58:43 UTC
I'm pretty certain that XFree 3.3.6 mimics the behavior described above from
XFree4, as I've had multiple problems in the past due to not putting in the
default color depth line.

Comment 3 Jeremy Katz 2000-06-22 03:16:24 UTC
This behavior persists in beta2

Comment 4 Jeremy Katz 2000-07-06 01:27:58 UTC
although mentioned on testers-list, still bumping this up to beta3 as it
persists there

Comment 5 Glen Foster 2000-07-18 18:21:54 UTC
This defect is considered MUST-FIX for Winston Beta-5

Comment 6 Matt Wilson 2000-07-18 22:34:43 UTC
Fixed in CVS, will be in beta4

Comment 7 Matt Wilson 2000-07-18 22:35:08 UTC
*** Bug 12126 has been marked as a duplicate of this bug. ***

Comment 8 Hans de Goede 2000-07-19 06:22:44 UTC
Resolution not a bug?!



Note You need to log in before you can comment on or make changes to this bug.