Bug 120199 - throttling
Summary: throttling
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-06 18:47 UTC by Łukasz Trąbiński
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 19:43:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Łukasz Trąbiński 2004-04-06 18:47:48 UTC
Description of problem:


Version-Release number of selected component (if applicable):
postfix-2.0.11-5

How reproducible:
install postfix

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Mar 28 23:12:35 oceanic postfix/master[8858]: daemon started --
version 2.0.11
Mar 28 23:12:59 oceanic postfix/master[8858]: warning: process
/usr/libexec/postfix/smtpd pid 8869 killed by signal 11
Mar 28 23:12:59 oceanic postfix/master[8858]: warning:
/usr/libexec/postfix/smtpd: bad command startup -- throttling
oceanic:~$ telnet oceanic 25
Trying 213.135.44.33...
Connected to oceanic.
Escape character is '^]'.

and waiting


Expected results:

oceanic:~$ telnet oceanic 25
Trying 213.135.44.33...
Connected to oceanic.
Escape character is '^]'.
220 oceanic.wsisiz.edu.pl ESMTP


Additional info:

in postfix.spec file we have line:

%define SASL 2
after change it to:
%define SASL 1
and added line:

%if %{SASL}
  %define sasl_v1_lib_dir %{_libdir}/sasl
  %define sasl_v2_lib_dir %{_libdir}/sasl2
  CCARGS="${CCARGS} -DUSE_SASL_AUTH"
  %if %{SASL} <= 1
    %define sasl_lib_dir %{sasl_v1_lib_dir}
    AUXLIBS="${AUXLIBS} -L%{sasl_lib_dir} -lsasl"
  %else
    %define sasl_lib_dir %{sasl_v2_lib_dir}
    CCARGS="${CCARGS} -I/usr/include/sasl"
    AUXLIBS="${AUXLIBS} -L%{sasl_lib_dir} -lsasl2"
  %endif

and rebuild it, postfix works fine.

more information:

System Fedora Core 1 or RedHat RH 9.

oceanic:~$ rpm -qa |grep sasl
cyrus-sasl-devel-2.1.15-6
cyrus-sasl-md5-2.1.15-6
cyrus-sasl-2.1.15-6
cyrus-sasl-plain-2.1.15-6

oceanic:~$ rpm -qa |grep openldap
openldap-2.0.27-8
openldap-servers-2.0.27-8
openldap-devel-2.0.27-8
openldap-clients-2.0.27-8


Here is out from postconf -n command:
http://lukasz.eu.org/postconf.txt

Older version of postfix (for example postfix 2.0.9) 
worked fine with this configuration

Comment 1 John Dennis 2004-04-06 19:43:37 UTC
Thank you for your bug fix. There was a problem with SASL linking in
the enterprise product and that was fixed a while ago, it sounds like
somehow you hit the same thing in FC1 which perplexes me because FC1
did not have this problem. The version of openlap for FC1 is 2.1.15-6.
I'm suspicious you have a vesion skew problem on your system somehow
between interrelated packages. I don't think this is an FC1 bug. You
may want to know however that postfix-2.0.16-1 is available for FC1
that does fix a problem with local SMTP clients such as pine, mh, etc.


Note You need to log in before you can comment on or make changes to this bug.