Bug 120201 - syslog not recording hostnames
syslog not recording hostnames
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sysklogd (Show other bugs)
3.0
s390x Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-06 14:59 EDT by Jennifer E. Lamb
Modified: 2014-03-16 22:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 13:10:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Customer syslog makefile compiled with 31 bit libraries (3.99 KB, text/plain)
2004-04-06 16:40 EDT, Jennifer E. Lamb
no flags Details

  None (edit)
Description Jennifer E. Lamb 2004-04-06 14:59:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
I have a customer that claims when a Zseries vm is used as a syslog
server it apparently is not recording the hostnames of the machines
itrecieves messages from and instead displays ???. 

The names are all resolvable via DNS and they tried /etc/hosts. They
have also tried passing the -x option to disable name lookups.  He
says he does not have this problem with x86 RHEL3 systems.

Here is an example of what he is getting in messages:

root@rel3001 sysconfig]# ../init.d/syslog restart 
Shutting down kernel logger: [  OK  ] 
Shutting down system logger: [  OK  ] 
Starting system logger: [  OK  ] 
Starting kernel logger: [  OK  ] 
[root@rel3001 sysconfig]# tail -f /var/log/messages 
Dec 31 08:36:02 rel3001 syslogd 1.4.1: restart (remote reception). 
Dec 31 08:36:02 rel3001 syslog: syslogd startup succeeded 
Dec 31 08:36:02 rel3001 kernel: klogd 1.4.1, log source =
/proc/kmsgstarted. 
Dec 31 08:36:02 rel3001 syslog: klogd startup succeeded 
Dec 31 08:36:02 rel3001 syslog: syslogd shutdown succeeded 
Dec 31 08:36:13 ??? kernel: Kernel logging (proc) stopped. 
Dec 31 08:36:13 ??? kernel: Kernel log daemon terminating. 
Dec 31 08:36:14 ??? syslog: klogd shutdown succeeded 
Dec 31 08:36:14 ??? exiting on signal 15 
Dec 31 08:36:14 ??? syslogd 1.4.1: restart. 
Dec 31 08:36:14 ??? syslog: syslogd startup succeeded 
Dec 31 08:36:14 ??? kernel: klogd 1.4.1, log source = /proc/kmsgstarted. 
Dec 31 08:36:14 ??? syslog: klogd startup succeeded 
Dec 31 08:36:16 ??? syslog: syslogd shutdown succeeded

Here is some strace information:Strace Information:
select(8, [0 7], NULL, NULL, NULL)      = 1 (in [7]) recvfrom(7,
"<6>kernel: Kernel logging (proc)"..., 1022, 0,  {sa_family=AF_UNSPEC,
sa_data="\1\0\0\1\205\230\0\0\1\0\0\1Q\10"}, [16])= 42
gettimeofday({1077910519, 317990}, NULL) = 0 writev(1, [{"Feb 27
11:35:19", 15}, {" ", 1}, {"???", 3}, {" ", 1},{"kernel:  Kernel
logging (proc) st"..., 39}, {"\n", 1}], 6) = 60 fsync(1)             
                  = 0 select(8, [0 7], NULL, NULL, NULL)      = 1 (in
[7]) recvfrom(7, "<6>kernel: Kernel log daemon ter"..., 1022, 0, 
{sa_family=AF_UNSPEC, sa_data="\1\0\0\1\205\230\0\0\1\0\0\1Q\10"},
[16])= 42 gettimeofday({1077910519, 366843}, NULL) = 0 writev(1,
[{"Feb 27 11:35:19", 15}, {" ", 1}, {"???", 3}, {" ", 1},{"kernel: 
Kernel log daemon termin"..., 39}, {"\n", 1}], 6) = 60 fsync(1)      
                         = 0 select(8, [0 7], NULL, NULL, NULL)      =
1 (in [7]) recvfrom(7, "<189>syslog: klogd shutdown succ"..., 1022, 0,
 {sa_family=AF_UNSPEC, sa_data="\1\0\0\1\205\230\0\0\1\0\0\1Q\10"},
[16])= 38 gettimeofday({1077910520, 500665}, NULL) = 0 writev(1,
[{"Feb 27 11:35:20", 15}, {" ", 1}, {"???", 3}, {" ", 1},{"syslog: 
klogd shutdown succeeded"..., 33}, {"\n", 1}], 6) = 54 fsync(1)      
                         = 0 writev(6, [{"Feb 27 11:35:20", 15}, {" ",
1}, {"???", 3}, {" ", 1},{"syslog:  klogd shutdown succeeded"..., 33},
{"\n", 1}], 6) = 54 fsync(6)                                = 0
select(8, [0 7], NULL, NULL, NULL)      = 1 (in [7]) recvfrom(7,
"<46>exiting on signal 15\n", 1022, 0,
{sa_family=AF_UNSPEC,sa_data="\1\0\0\1\205\230\0\0\1\0\0\1Q\10"},
[16]) = 25 gettimeofday({1077910520, 589891}, NULL) = 0 writev(1,
[{"Feb 27 11:35:20", 15}, {" ", 1}, {"???", 3}, {" ", 1},{"exiting  on
signal 15 ", 21}, {"\n", 1}], 6) = 42 fsync(1)                       
        = 0 select(8, [0 7], NULL, NULL, NULL)      = 1 (in [7])
recvfrom(7, "<46>syslogd 1.4.1: restart.\n", 1022, 0,{sa_family=AF_UNSPEC,

The customer thinks the problem is somewhere in the 64 bit libraries.
Heclaims compiling and linking sysklog-1.4.1 against the 31bit
libraries resolves this issue. 

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Whether this can be reproduced remains to be seen.  Requires
additional testing.  Customer is confident that rebuilding syslog
resolves this issue.
Comment 1 Jennifer E. Lamb 2004-04-06 16:40:41 EDT
Created attachment 99160 [details]
Customer syslog makefile compiled with 31 bit libraries
Comment 2 Jennifer E. Lamb 2004-04-06 16:42:00 EDT
Here are the relevant lines of the Makefile on the root of the
syslog-1.4.1 source tree:

CFLAGS= $(RPM_OPT_FLAGS) -O3 -m31 -DSYSV -fomit-frame-pointer -Wall
-fno-strengtLDFLAGS= -s -m31LIBS = /usr/lib/libresolv.a

Of course this is really intermediate stuff and involves setting the
m31 switch for gcc and for ld to force the binary to 31 bit. This
along with explicitly using /usr/lib/libresolv.a, as opposed to the
libresolv in /usr/lib64, compiles without complaint and seems solves
the issue with not resolving addresses when syslog receives a message
from any remote host.

Also, if you try to compile syslog-1.4.1 under the 64 bit libraries
the same inability to resolve addresses on incoming remote log
messages is seen.
Comment 3 Bill Nottingham 2004-04-06 18:02:23 EDT
Reproduced. Oddly, doesn't affect other 64-bit platforms.
Comment 9 Pete Zaitcev 2004-04-07 17:44:27 EDT
I verified that 1.4.1-12.1 fixes the problem and that it passes
a sanity check on an RHEL3 U2 Beta s390x system.
Comment 10 Florian La Roche 2004-04-12 08:10:29 EDT
-12.1 is included in the beta channel, setting this to modified
Comment 11 Suzanne Hillman 2004-05-06 13:10:31 EDT
Verified.

Note You need to log in before you can comment on or make changes to this bug.