Bug 120202 - High Throughput Transfers of Large Files Fail
High Throughput Transfers of Large Files Fail
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mozilla (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-06 15:03 EDT by Chris Hollowell
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-09 10:36:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Hollowell 2004-04-06 15:03:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
When receiving large files (500 MB+: specifically ISO 9660 images
in my case) from an FTP or HTTP server at sustained rates of greater
than 3 MB/s with Mozilla 1.4.2, the transfer frequently terminates
prematurely.  Furthermore, when a transfer fails, Mozilla indicates
that the file has been received in its entirety, when in fact only a
portion of the file has been transfered.

An examination of a failed transfer with tcpdump has yielded
that my system is transmitting a TCP packet with the RESET flag
set to the FTP/HTTP server, thus breaking the connection.

The problem is NOT occurring with Netscape 7.1, wget, BSD ftp, or
Mozilla 1.0.2 (tried all on the same system).  It is also
occurring with Mozilla 1.4, Mozilla 1.6 and Firefox 0.8.

I disabled the stateful firewall rules on my machine, thinking
netfilter may have been malfunctioning, but saw the same behavior.

I've verified (rpm -V) the integrity of the mozilla packages,
as well as all packages they depend on (and the kernel package).

I've tried creating a new ~/.mozilla directory, but the problem
still occurs.

I've tried adjusting the Mozilla cache size parameter (lower and
higher), to no avail.

A colleague of mine is able to reproduce this error on his RHEL
3.0 WS system.

I have all of the latest errata applied.


Version-Release number of selected component (if applicable):
mozilla-1.4.2-3.0.2

How reproducible:
Sometimes

Steps to Reproduce:
1.  Start Mozilla 1.4.2.
2.  Retrieve a large file (500+ MB) from an FTP or HTTP server at a
    transfer rate greater than 3 MB/s.

Actual Results:  Transfer terminates prematurely (retrieved file is
truncated), Download Manager indicates 100% complete.

Expected Results:  The file is received in its entirety.

Additional info:

System information:
kernel: 2.4.21-9.0.1.EL
ethernet card: Intel 82540EM Gigabit Ethernet Controller 
               (e1000)
CPU: Pentium 4 2.4 GHz
RAM: 512 MB
HDD: UDMA100 IDE Drive

http://bugzilla.mozilla.org/show_bug.cgi?id=168846 documents
the download status issue, but not the TCP RESETs I've been seeing.
Comment 1 Christopher Blizzard 2004-04-12 15:08:56 EDT
There were some late-breaking fixes that might have fixed this (mostly
related to the disk cache.)  Can you download a Mozilla or Firefox
nightly and see if the problem still occurs there?
Comment 2 Chris Hollowell 2004-04-14 12:27:11 EDT
The problem is still occurring with the 4/13/2004 Mozilla 1.7b nightly
build.
Comment 3 Matěj Cepl 2007-02-09 10:36:42 EST
Since this bugzilla report was filed, there have been several major updates,
which may have resolved this issue. Users who have experienced this problem are
encouraged to upgrade their system to the latest version available. Therefore
closing this bug as obsolete.

If you experience this problem on the up-to-date system, please reopen this bug
with an additional information.

Note You need to log in before you can comment on or make changes to this bug.