Bug 120251 - Zulu help text not translated in Anaconda
Zulu help text not translated in Anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 07:10 EDT by David Fraser
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 18:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
zulu "about to install" screen showing lack of help translation (93.91 KB, image/png)
2004-04-07 07:12 EDT, David Fraser
no flags Details
patch to add missing languages to anaconda help build (644 bytes, patch)
2004-04-07 09:31 EDT, David Fraser
no flags Details | Diff

  None (edit)
Description David Fraser 2004-04-07 07:10:49 EDT
The left "Help Text" panel is not translated when selecting a Zulu
install in Anaconda.

Version-Release number of selected component (if applicable):
Fedora Core 2 Test 2

How reproducible:
Consistently

Steps to Reproduce:
1. Boot from the Fedora Core 2 Test 2 CD.
2. Select Zulu as the language when asked
3. 
  
Actual results:
All the Help text is in English

Expected results:
The Help text should be in Zulu

Additional info:
Anaconda is listed as almost entirely translated at the URL:
http://elvis.redhat.com/cgi-bin/i18n-status?locale=zu&module=anaconda&rm=mode5&referrer=mode7
So this is probably a bug
Comment 1 David Fraser 2004-04-07 07:12:03 EDT
Created attachment 99181 [details]
zulu "about to install" screen showing lack of help translation

attached zulu "about to install" screen showing lack of help translation.
all the install screens are like this.
Comment 2 David Fraser 2004-04-07 09:30:11 EDT
This seems to be because zu is not included in LANG or I18N_LANG
help/Makefile in anaconda-help-9.2 source rpm
Presumably all languages included should be in these variables even if
translations are partial - zu is complete, as are hr and bn which are
also missing from the variables.
I will attach a patch to include all missing languages
Comment 3 David Fraser 2004-04-07 09:31:17 EDT
Created attachment 99185 [details]
patch to add missing languages to anaconda help build
Comment 4 Bill Nottingham 2004-04-07 18:05:18 EDT
Done differently in CVS (basically, just include whatever's there.)

Will be fixed in the next anaconda build (approximately 2 hours after
all the malformed docbook in the translations is fixed. :) )
Comment 5 Bill Nottingham 2004-04-07 18:05:39 EDT
Erm, that's 'anaconda-help' build.

Note You need to log in before you can comment on or make changes to this bug.