Bug 120262 - slow outbound performance of the r8169 driver
Summary: slow outbound performance of the r8169 driver
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 118637 123574
TreeView+ depends on / blocked
 
Reported: 2004-04-07 13:38 UTC by Bastien Nocera
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 20:55:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for TX IRQ handling (1.41 KB, patch)
2004-04-08 09:55 UTC, Bastien Nocera
no flags Details | Diff
r8169-1.4-patch (1.64 KB, text/plain)
2004-05-14 16:08 UTC, Bastien Nocera
no flags Details
r8169-backport.patch (40.04 KB, patch)
2004-06-16 19:27 UTC, John W. Linville
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:550 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 3 Update 4 2004-12-20 05:00:00 UTC

Description Bastien Nocera 2004-04-07 13:38:27 UTC
The problem is similar to:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=117691

With /home/users/ being an NFS share:
# time dd if=/dev/zero of=/home/users/tmp/testfile_wr bs=16k count=16384
16384+0 enregistrements lus.
16384+0 enregistrements ecrits.

real    2m0.944s
user    0m0.010s
sys     0m0.660s

# time dd if=/home/users/tmp/testfile_rd of=/dev/null bs=16k
16384+0 enregistrements lus.
16384+0 enregistrements ecrits.

real    0m26.131s
user    0m0.020s
sys     0m0.300s

Using another network card (Realtek 8139) shows decent outbound speed
(around 36 seconds with the 8139 card).
The machine is on a 10/100 network, with the cards set at 100Mbps.

This is with kernel 2.4.21-9.EL and 2.4.21-9.0.1.EL

Comment 1 Bastien Nocera 2004-04-08 09:55:54 UTC
Created attachment 99232 [details]
patch for TX IRQ handling

Patch provided by the customer, Olivier Lepape <ol@m2000.fr>

Comment 2 Don Howard 2004-04-28 22:24:21 UTC
I can confirm that the above patch builds against the latest RHEL 
devel kernel 2.4.21-14.   

Comment 3 Don Howard 2004-04-28 22:42:53 UTC
Also, the customer's patch is is very similar to what is in current 
upstream 2.4. 

Comment 5 Bastien Nocera 2004-05-14 16:08:46 UTC
Created attachment 100228 [details]
r8169-1.4-patch

Updated patch, fixes a potential deadlock.

Comment 8 John W. Linville 2004-06-16 19:27:57 UTC
Created attachment 101195 [details]
r8169-backport.patch

Backport from upstream 2.4.27-pre5 kernel...

Comment 12 John W. Linville 2004-06-25 14:29:41 UTC
Testing w/ backported driver shows greatly improved results here...

/home/devel/linville
[dhcp59-161]:> time dd if=/dev/zero of=testfile_wr bs=16k count=16386
16386+0 records in
16386+0 records out

real    0m23.320s
user    0m0.030s
sys     0m0.450s

/home/devel/linville
[dhcp59-161]:> time dd if=testfile_rd of=/dev/null bs=16k
16386+0 records in
16386+0 records out

real    0m9.217s
user    0m0.020s
sys     0m0.100s


Comment 16 Ernie Petrides 2004-08-31 04:11:18 UTC
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-20.1.EL).


Comment 17 John Flanagan 2004-12-20 20:55:01 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html



Note You need to log in before you can comment on or make changes to this bug.