Bug 120263 - ypserv problems ypmatching netgroup entries
ypserv problems ypmatching netgroup entries
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ypserv (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 09:44 EDT by Thomas J. Baker
Modified: 2015-01-07 19:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:28:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2004-04-07 09:44:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Galeon/1.3.14

Description of problem:
I was switching over a ypserver from an SGI machine to one of our
RHEL3 linux servers. When I initially did the switch, I had problems
with netgroups. I could ypcat netgroups but doing a ypmatch on any key
in the netgroup didn't work. I then tested the same yp configuration
on an FC2T2 system and everything worked fine. The netgroups were fine
and everything worked as expected. I then went back to the RHEL3
machine and tried again and had the same result. You could ypcat the
netgroup file but ypmatches failed. This caused lots of problems with
exports, automounts, etc. I then pointed the RHEL3 system at my FC2T2
system (reconfig/restart ypbind) and the netgroup problem went away.
This lead me to believe it was a problem with ypserv.

As a test I rebuilt the rawhide ypserv-2.12.1-2 and tried it on the
RHEL3 system and everything worked as expected. I don't really have
more details as I needed to get this working quickly and didn't have
time for extensive debugging. I've got to believe that the problem is
related to our netgroup file as I've set up another ypserver on an
RHEL3 system with smaller maps and everything just worked.

I can provide copies of any files you need if you want to persue this.

Version-Release number of selected component (if applicable):
ypserv-2.8-1

How reproducible:
Always

Steps to Reproduce:
1. set up yp from previous existing src files
2. start ypserv
3.
    

Actual Results:  most everything works except the netgroup matching

Expected Results:  everything works

Additional info:
Comment 1 Simon Oliver 2004-08-06 04:40:43 EDT
I have a simillar problem with ypserv and yppasswd changing.  I have
reported this as bug 129308.
Comment 2 Charles C. Figueiredo 2005-03-24 10:58:29 EST
I've had issues like this as well, specifically when migrating NIS masters from 
Solaris to RHEL. The only problematic map being the netgroup map -- cleaning up 
all stray spaces at the end of entries as well as making sure each continuation 
of a list is properly formated with *tabs* rather than spaces fixes this for 
me. Once I did this, netgroups started working fine.

-charles.
Comment 3 RHEL Product and Program Management 2007-10-19 15:28:00 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.