Bug 120319 - kudzu detect ISDN-Card (AVM PCI Fritz!PCI v2.0) as ethx
kudzu detect ISDN-Card (AVM PCI Fritz!PCI v2.0) as ethx
Status: CLOSED DUPLICATE of bug 116855
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 15:20 EDT by Uwe Beck
Modified: 2014-03-16 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2004-04-07 15:20:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
For FC2test2 an ISDN card is an ethernet interface.

Hardware: 2 x 3COM (3c59x)
          1 x Intel (e100)
          1 x AVM PCI Fritz!PCI v2.0 (hisax_fcpcipnp)

I install FC2test2 over NFS (ISO-images) over the onboard Intel (e100)
network card. This card is after installation eth2.
After reboot network does not work on eth2.

Here is the reason:

/etc/modprobe.conf after installation:

alias eth0 hisax_fcpcipnp
alias eth1 3c59x
alias eth2 3c59x
alias .0 e100

The correct /etc/modprobe.conf for the system:

alias eth0 3c59x
alias eth1 3c59x
alias eth2 e100

I remove the false eth0 with system-config-network in hardware window
and create the ethernet cards correct. Then I configure ISDN and save
the configuration. Every time I start system-config-network now I see
in the hardware window:

Fritz!PCI v2.0 ISDN    Ethernet eth2 Ok
3Com 3c590/3c595/3c90x Ethernet eth0 System
3Com 3c590/3c595/3c90x Ethernet eth1 System
AVM PCI (Fritz!PCI v2) ISDN     ISDN Card configured

After I do the corrections by hand the system works.
It should be also work correct after installation. At this time I am
not able to login remote after installation is finished.


Version-Release number of selected component (if applicable):
kudzu-1.1.53-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC2test2 over NFS (ISO-images)
2. Reboot the system after installation finished
3.
    

Actual Results:  no network after installation, ISDN card is ethx for
system-config-network

Expected Results:  all cards should be detect correct so that after
reboot the network are available

Additional info:
Comment 1 Bill Nottingham 2004-04-07 17:19:41 EDT

*** This bug has been marked as a duplicate of 116855 ***
Comment 2 jens.koerber 2004-09-18 10:03:53 EDT
works with kudzu-1.1.36.3-1

-------------------------
Sep 18 15:27:29 localhost kernel: ISDN subsystem Rev:
1.1.4.1/1.1.4.1/1.1.4.1/1.1.4.1/1.1.4.1/1.1.4.1 loaded
Sep 18 15:27:29 localhost kernel: HiSax: Linux Driver for passive ISDN
cards
Sep 18 15:27:29 localhost kernel: HiSax: Version 3.5 (module)
Sep 18 15:27:29 localhost kernel: HiSax: Layer1 Revision 1.1.4.1
Sep 18 15:27:29 localhost kernel: HiSax: Layer2 Revision 1.1.4.1
Sep 18 15:27:29 localhost kernel: HiSax: TeiMgr Revision 1.1.4.1
Sep 18 15:27:29 localhost kernel: HiSax: Layer3 Revision 1.1.4.1
Sep 18 15:27:29 localhost kernel: HiSax: LinkLayer Revision 1.1.4.1
Sep 18 15:27:29 localhost kernel: HiSax: Approval certification failed
because of
Sep 18 15:27:29 localhost kernel: HiSax: unauthorized source code changes
Sep 18 15:27:29 localhost kernel: HiSax module removed
Sep 18 15:27:29 localhost kernel: ISDN-subsystem unloaded
Sep 18 15:27:34 localhost kernel: ISDN subsystem Rev:
1.1.4.1/1.1.4.1/1.1.4.1/1.1.4.1/1.1.4.1/1.1.4.1 loaded
Sep 18 15:27:34 localhost kernel: HiSax: Linux Driver for passive ISDN
cards
Sep 18 15:27:34 localhost kernel: HiSax: Version 3.5 (module)
Sep 18 15:27:34 localhost kernel: HiSax: Layer1 Revision 1.1.4.1
Sep 18 15:27:34 localhost kernel: HiSax: Layer2 Revision 1.1.4.1
Sep 18 15:27:34 localhost kernel: HiSax: TeiMgr Revision 1.1.4.1
Sep 18 15:27:34 localhost kernel: HiSax: Layer3 Revision 1.1.4.1
Sep 18 15:27:34 localhost kernel: HiSax: LinkLayer Revision 1.1.4.1
Sep 18 15:27:34 localhost kernel: HiSax: Approval certification failed
because of
Sep 18 15:27:34 localhost kernel: HiSax: unauthorized source code changes
Sep 18 15:27:34 localhost kernel: HiSax module removed
Sep 18 15:27:34 localhost kernel: ISDN-subsystem unloaded


--------------------------------------
$pppd call isdn/avm usepeerdns
--------------------------------------

Sep 18 15:59:43 localhost pppd[6994]: Plugin userpass.so loaded.
Sep 18 15:59:43 localhost pppd[6994]: userpass: $Revision: 1.4 $
Sep 18 15:59:43 localhost pppd[6994]: Plugin capiplugin.so loaded.
Sep 18 15:59:43 localhost pppd[6994]: capiplugin: $Revision: 1.32 $
Sep 18 15:59:43 localhost pppd[6994]: capiconn:  1.7 
Sep 18 15:59:43 localhost pppd[6995]: pppd 2.4.1 started by root, uid 0
Sep 18 15:59:43 localhost pppd[6995]: capiplugin: phase serialconn.
Sep 18 15:59:43 localhost pppd[6995]: capiplugin: dialing 03039984330
(hdlc)
Sep 18 15:59:43 localhost kernel: kcapi: appl 3 up
Sep 18 15:59:46 localhost kernel: kcapi: appl 3 ncci 0x10101 up
Sep 18 15:59:46 localhost pppd[6995]: capiplugin: connected: "" ->
"03039984330" outgoing (pcli=0x101/ncci=0x10101)
Sep 18 15:59:46 localhost pppd[6995]: capiplugin: using /dev/capi/0:
"" -> "03039984330" outgoing (pcli=0x101/ncci=0x10101)
Sep 18 15:59:47 localhost pppd[6995]: Using interface ppp1
Sep 18 15:59:47 localhost pppd[6995]: Connect: ppp1 <--> /dev/capi/0
Sep 18 15:59:47 localhost pppd[6995]: capiplugin: phase establish (was
serialconn).
Sep 18 15:59:47 localhost pppd[6995]: capiplugin: phase authenticate
(was establish).
Sep 18 15:59:47 localhost pppd[6995]: capiplugin: phase network (was
authenticate).
Sep 18 15:59:48 localhost modprobe: modprobe: Can't locate module
ppp-compress-21
Sep 18 15:59:48 localhost kernel: PPP Deflate Compression module
registered
Sep 18 15:59:48 localhost modprobe: modprobe: Can't locate module
ppp-compress-21
Sep 18 15:59:51 localhost pppd[6995]: not replacing existing default
route to ppp0 [217.5.98.33]
Sep 18 15:59:51 localhost pppd[6995]: local  IP address 192.168.113.217
Sep 18 15:59:51 localhost pppd[6995]: remote IP address 212.42.244.69
Sep 18 15:59:51 localhost pppd[6995]: primary   DNS address 192.168.113.8
Sep 18 15:59:51 localhost pppd[6995]: capiplugin: phase running (was
network).

-------------------------------------------------------
$adsl-stop
$killall pppd
-------------------------------------------------------

Sep 18 16:00:15 localhost adsl-stop: Killing pppd
Sep 18 16:00:15 localhost pppd[1334]: Terminating on signal 15.
Sep 18 16:00:15 localhost adsl-stop: Killing adsl-connect
Sep 18 16:00:16 localhost pppd[1334]: Connection terminated.
Sep 18 16:00:16 localhost pppd[1334]: Connect time 36.8 minutes.
Sep 18 16:00:16 localhost pppd[1334]: Sent 253451 bytes, received
1794159 bytes.
Sep 18 16:00:16 localhost pppoe[1335]: read (asyncReadFromPPP):
Session 3649: Input/output error
Sep 18 16:00:16 localhost pppoe[1335]: Sent PADT
Sep 18 16:00:16 localhost pppd[1334]: Exit.
Sep 18 16:00:24 localhost pppd[6995]: Terminating on signal 15.
Sep 18 16:00:24 localhost pppd[6995]: capiplugin: phase terminate (was
running).
Sep 18 16:00:24 localhost pppd[6995]: capiplugin: phase network (was
terminate).
Sep 18 16:00:24 localhost pppd[6995]: capiplugin: phase terminate (was
network).
Sep 18 16:00:24 localhost pppd[6995]: capiplugin: phase dead (was
terminate).
Sep 18 16:00:24 localhost kernel: kcapi: appl 3 ncci 0x10101 down
Sep 18 16:00:24 localhost pppd[6995]: Hangup (SIGHUP)
Sep 18 16:00:25 localhost pppd[6995]: capiplugin: disconnect(local):
"" -> "03039984330" outgoing (pcli=0x101/ncci=0x10101) 0x3400 (0x3301)
- No additional information
Sep 18 16:00:25 localhost pppd[6995]: Connection terminated.
Sep 18 16:00:25 localhost pppd[6995]: Connect time 0.7 minutes.
Sep 18 16:00:25 localhost pppd[6995]: Sent 193 bytes, received 153 bytes.
Sep 18 16:00:25 localhost pppd[6995]: tcflush failed: Input/output error
Sep 18 16:00:25 localhost pppd[6995]: capiplugin: phase disconnect
(was dead).
Sep 18 16:00:26 localhost pppd[6995]: capiplugin: exit
Sep 18 16:00:26 localhost pppd[6995]: Exit.
Sep 18 16:00:26 localhost kernel: kcapi: appl 3 down
Comment 3 Red Hat Bugzilla 2006-02-21 14:02:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.