Bug 120322 - slapd fails to start if policy is enforced
slapd fails to start if policy is enforced
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 15:28 EDT by Albert Strasheim
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 10:36:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2004-04-07 15:28:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
With policy enforced, slapd fails to start:

pr  7 21:30:00 asok kernel: audit(1081366200.705:0): avc:  denied  {
search } for  pid=16759 exe=/usr/sbin/slapd name=root dev=hda5
ino=1310721 scontext=root:system_r:slapd_t
tcontext=root:object_r:staff_home_dir_t tclass=dir
Apr  7 21:30:00 asok kernel: audit(1081366200.705:0): avc:  denied  {
search } for  pid=16759 exe=/usr/sbin/slapd name=root dev=hda5
ino=1310721 scontext=root:system_r:slapd_t
tcontext=root:object_r:staff_home_dir_t tclass=dir
Apr  7 21:30:00 asok kernel: audit(1081366200.714:0): avc:  denied  {
setgid } for  pid=16759 exe=/usr/sbin/slapd capability=6
scontext=root:system_r:slapd_t tcontext=root:system_r:slapd_t
tclass=capability

With enforcement disabled (setenforce 0), slapd starts but the
following errors are generated:

Apr  7 21:32:32 asok kernel: audit(1081366352.811:0): avc:  denied  {
search } for  pid=16808 exe=/usr/sbin/slapd name=root dev=hda5
ino=1310721 scontext=root:system_r:slapd_t
tcontext=root:object_r:staff_home_dir_t tclass=dir
Apr  7 21:32:32 asok kernel: audit(1081366352.821:0): avc:  denied  {
setgid } for  pid=16808 exe=/usr/sbin/slapd capability=6
scontext=root:system_r:slapd_t tcontext=root:system_r:slapd_t
tclass=capability
Apr  7 21:32:32 asok kernel: audit(1081366352.821:0): avc:  denied  {
setuid } for  pid=16808 exe=/usr/sbin/slapd capability=7
scontext=root:system_r:slapd_t tcontext=root:system_r:slapd_t
tclass=capability

If slapd is restarted again, the following errors are generated:

Apr  7 21:33:00 asok kernel: audit(1081366380.775:0): avc:  denied  {
search } for  pid=16833 exe=/usr/sbin/slapd name=root dev=hda5
ino=1310721 scontext=root:system_r:slapd_t
tcontext=root:object_r:staff_home_dir_t tclass=dir

If slapd is restarted yet again, no errors are displayed.

Version-Release number of selected component (if applicable):
policy-1.9.2-12 openldap-2.1.25-5.1

How reproducible:
Always

Steps to Reproduce:
1. /etc/init.d/slapd start
2. setenforce 0
3. /etc/init.d/slapd start
4. /etc/init.d/slapd restart
5. /etc/init.d/slapd restart
    

Actual Results:  slapd fails to start or generated errors

Expected Results:  slapd should work

Additional info:
Comment 1 Albert Strasheim 2004-04-07 15:31:39 EDT
Whoops. Make that /etc/init.d/ldap, not slapd.
Comment 2 Daniel Walsh 2004-04-08 08:57:02 EDT
Fixed in policy-1.10.1-4
Comment 3 Albert Strasheim 2004-04-08 10:26:17 EDT
Works for me.

Note You need to log in before you can comment on or make changes to this bug.