This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 120332 - Quarterly Monotype font downloads report
Quarterly Monotype font downloads report
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
rhn350
All Linux
high Severity medium
: ---
: ---
Assigned To: Chris MacLeod
Fanny Augustin
:
Depends On:
Blocks: 111679
  Show dependency treegraph
 
Reported: 2004-04-07 16:02 EDT by dff
Modified: 2007-03-27 00:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 14:23:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dff 2004-04-07 16:02:18 EDT
Starting with Red Hat Enterprise Linux 3 Update 2, we are including a set
of commercial fonts licensed from Monotypes in the RHEL 3 'Extras' ISO and on
the RHEL 'Extras' channels.  This applies to all RHEL 3 beta and GA releases
including and after RHEL 3 Update 2, including Red Hat Desktop v. 3.   The fonts
are in a package called 'fonts-monotype'.

For example, fonts-monotype package from the RHEL 3 AS x86 Update 2 Extras Beta
channel:
  https://rhn.redhat.com/network/software/packages/details.pxt?pid=218657

According to the License Agreement with Monotype, Red Hat is required to send a 
Quarterly report to Monotype that indicates the number of copies of the font
distributed by Red Hat, which is used to calculate the royalties payable to
Monotype as a result.  Will Sendall is responsible for generating the report and
royalty payment information.

The request is thus for RHN to assist in creating a report that we can run at
least quarterly for Will Sendall, which counts:

  * total downloads of individual fonts-monotype package from RHN in the quarter
      (for all applicable products/architectures, meaning all versions
       of RHEL including and after RHEL 3 Update 2, including
       Red Hat Desktop v. 3)

  * total downloads of the 'Extras CD' ISOs containing fonts-monotype
      in the quarter (for all applicable products/architectures, meaning 
      all versions of RHEL including and after RHEL 3 Update 2, including
      Red Hat Desktop v. 3)

My understanding is that the first royalty report including shipments of the
Monotype fonts with RHEL products will be due to Monotype by approx. July 29, 2004.

Excerpt from Mark Webbink mail:

> We should not have any trouble with 
> existing approaches to monitor the production and distribution of 
> physical units.  What we will need is a means to count the number of RHN 
> downloads of either the fonts alone or in combination with other 
> offerings.  I am not sufficiently familiar with RHN and what it tracks 
> to know how that can be done, but that is what needs to be determined, 
> and those reports need to go back to Will.
Comment 2 Joe deBlaquiere 2004-04-13 14:02:39 EDT
Plan is to generate report Monthly

grep logs, report to wsendall @ dff

Chip to hand off RT to ProdOps

Comment 3 Matt Jamison 2004-05-04 14:51:12 EDT
do I need to do anything to test this?
Comment 4 Chris MacLeod 2004-05-04 14:55:03 EDT
no, it's for after the release of the desktop product I believe and is between
me to write the report and prod ops to implement it in production.
Comment 5 Chris MacLeod 2004-06-14 16:53:21 EDT
cvs/rhn/scripts/package-report.pl

perl package-report.pl \
    --filename fonts-monotype \
    --filename rhel-3-lacd-U2-i386.iso \
    --filename rhel-3-lacd-U2-ia64.iso \
    --filename rhel-3-lacd-U2-x86_64.iso \
    [ --email recipients ]
    some regex that covers all relavent logfiles

Comment 6 Chris MacLeod 2004-11-10 14:23:43 EST
being run on sync.rhndev (access to prod logs)

Note You need to log in before you can comment on or make changes to this bug.