Bug 120359 - Kernel generates many errors related to avc : denied.
Kernel generates many errors related to avc : denied.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-07 19:40 EDT by shane nuessler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 08:47:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shane nuessler 2004-04-07 19:40:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Here is an extract of dmesg,

audit(1081381090.894:0): avc:  denied  { setexec } for  pid=1710
exe=/usr/bin/gdm-binary scontext=system_u:system_r:kernel_t
tcontext=system_u:system_r:kernel_t tclass=process
audit(1081381090.895:0): avc:  denied  { transition } for  pid=1710
exe=/usr/bin/gdm-binary path=/etc/X11/xdm/Xsession dev=hda1 ino=308362
scontext=system_u:system_r:kernel_t
tcontext=u4035491:sysadm_r:sysadm_t tclass=process
audit(1081381090.909:0): avc:  denied  { siginh } for  pid=1710
exe=/bin/bash scontext=system_u:system_r:kernel_t
tcontext=u4035491:sysadm_r:sysadm_t tclass=process
audit(1081381090.909:0): avc:  denied  { rlimitinh } for  pid=1710
exe=/bin/bash scontext=system_u:system_r:kernel_t
tcontext=u4035491:sysadm_r:sysadm_t tclass=process
audit(1081381090.909:0): avc:  denied  { noatsecure } for  pid=1710
exe=/bin/bash scontext=system_u:system_r:kernel_t
tcontext=u4035491:sysadm_r:sysadm_t tclass=process
audit(1081381114.239:0): avc:  denied  { unix_read unix_write } for 
pid=1700 exe=/usr/X11R6/bin/XFree86 key=0
scontext=system_u:system_r:kernel_t
tcontext=u4035491:sysadm_r:sysadm_t tclass=shm
audit(1081381114.239:0): avc:  denied  { read write } for  pid=1700
exe=/usr/X11R6/bin/XFree86 key=0 scontext=system_u:system_r:kernel_t
tcontext=u4035491:sysadm_r:sysadm_t tclass=shm
audit(1081381114.239:0): avc:  denied  { use } for  pid=1700
path=/SYSV00000000 (deleted) dev= ino=131072
scontext=system_u:system_r:kernel_t
tcontext=u4035491:sysadm_r:sysadm_t tclass=fd
audit(1081381114.239:0): avc:  denied  { getattr associate } for 
pid=1700 exe=/usr/X11R6/bin/XFree86 key=0
scontext=system_u:system_r:kernel_t
tcontext=u4035491:sysadm_r:sysadm_t tclass=shm
audit(1081381118.402:0): avc:  denied  { execute } for  pid=2059
exe=/bin/bash name=xkbcomp dev=hda1 ino=876857
scontext=system_u:system_r:kernel_t
tcontext=u4035491:object_r:user_home_t tclass=file
audit(1081381118.402:0): avc:  denied  { execute_no_trans } for 
pid=2059 exe=/bin/bash path=/usr/X11R6/lib/X11/xkb/xkbcomp dev=hda1
ino=876857 scontext=system_u:system_r:kernel_t
tcontext=u4035491:object_r:user_home_t tclass=file
audit(1081381118.493:0): avc:  denied  { ioctl } for  pid=1700
exe=/usr/X11R6/bin/XFree86 path=/dev/tty7 dev=hda1 ino=38858
scontext=system_u:system_r:kernel_t
tcontext=system_u:object_r:tty_device_t tclass=chr_file
PCI: Setting latency timer of device 0000:00:1f.5 to 64
intel8x0_measure_ac97_clock: measured 49649 usecs
intel8x0: clocking to 41178
audit(1081381122.744:0): avc:  denied  { getattr } for  pid=2077
exe=/sbin/udev path=/sys/class/sound/pcmC0D1c/driver dev= ino=4383
scontext=system_u:system_r:kernel_t tcontext=system_u:object_r:sysfs_t
tclass=lnk_file
audit(1081381122.756:0): avc:  denied  { read } for  pid=2077
exe=/sbin/udev name=driver dev= ino=4383
scontext=system_u:system_r:kernel_t tcontext=system_u:object_r:sysfs_t
tclass=lnk_file
audit(1081381190.596:0): avc:  denied  { read } for  pid=1340
exe=/usr/sbin/gpm name=tty0 dev=hda1 ino=38829
scontext=system_u:system_r:kernel_t
tcontext=system_u:object_r:tty_device_t tclass=chr_file
audit(1081381217.400:0): avc:  denied  { transition } for  pid=2209
exe=/bin/su path=/usr/X11R6/bin/xauth dev=hda1 ino=1087970
scontext=u4035491:sysadm_r:sysadm_t tcontext=root:sysadm_r:sysadm_t
tclass=process


Version-Release number of selected component (if applicable):
kernel-2.6.4-1.305

How reproducible:
Always

Steps to Reproduce:
1.reboot
2.
3.
    

Actual Results:  errors

Expected Results:  no errors

Additional info:
Comment 1 Daniel Walsh 2004-04-08 08:47:49 EDT
Looks like you have a partially install SELinux system.  You can add
selinux=0 to grup line to turn it off, or you can relabel the file
system.  Please refer to the FAQ for information on SELinux

Note You need to log in before you can comment on or make changes to this bug.