Bug 120360 - Driver not found for PXE/NFS install (via-rhine)
Driver not found for PXE/NFS install (via-rhine)
Status: CLOSED DUPLICATE of bug 120289
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-04-07 20:13 EDT by Jamie Guinan
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci -v output from a previous installation (fc2test1) (3.68 KB, text/plain)
2004-04-07 20:15 EDT, Jamie Guinan
no flags Details

  None (edit)
Description Jamie Guinan 2004-04-07 20:13:14 EDT
Description of problem:

Doing PXE install, kernel successfully loads via-rhine driver 
(see below), but doesn't recognize device for install phase.

tty3 contains,
  * loaded via-rhine from /modules/modules.cgz
  * inserted /tmp/via-rhine.ko

tty4 contains,
  <6>eth0: VIA VT6102 Rhine-II at 0xdffffe00, ..., IRQ 11

Version-Release number of selected component (if applicable):

How reproducible:
every time (is that what you're asking?)

Steps to Reproduce:
1. Boot via PXE (images/pxeboot/vmlinuz, images/pxeboot/initrd.img)
2. At [Installation Method] screen, select "NFS image"
Actual results:

Next screen reports "No driver found", and prompts for
  Select Driver|User a driver disk | Back

Driver not found under Select Driver.  There is no driver
disk, afaict.

Expected results:

Loaded driver should be used.

Additional info:

Will attach lspci -v output in next step.
Comment 1 Jamie Guinan 2004-04-07 20:15:05 EDT
Created attachment 99218 [details]
lspci -v output from a previous installation (fc2test1)
Comment 2 Jamie Guinan 2004-04-07 21:16:31 EDT
For reference, this is a SOYO SY-K7VME motherboard, w/1.6GHz Duron cpu
Comment 3 Jeremy Katz 2004-04-07 21:50:31 EDT
Probably related to bug 120289...
Comment 4 Jeff Moe (jebba) 2004-04-14 13:07:01 EDT
I can confirm this bug on a mini-itx board with dual on-board
via-rhine. Console 4 shows eth0 & eth1 found VT6102 and the module
loaded. Via-rhine is not in the list "Select Device Driver to Load".
This stops installation...
Comment 5 Guy Van Den Bergh 2004-04-19 19:11:28 EDT
Same thing as Jebba here.
The board is a dual-nic via epia cl10000, onboard via rhine nics.
Network install is not working, however an FC1 install from cd worked
fine before (with working network after install, I mean).
Comment 6 Guy Van Den Bergh 2004-04-19 19:28:01 EDT
Bummer. I tried boot.iso from FC1.
I can get on the network now but it complains the stage2.img doesn't
match my cd media.
Comment 7 Jamie Guinan 2004-04-25 08:17:00 EDT
I don't think this has anything to do with the PXE/network
after all.  I tried doing a "hard drive" install this morning,
and got the same "No driver found", prompt for Select Driver, etc.

My best guess is that /sbin/loader is getting confused by 
my machine's configuration.  Did I mention that I do _not_
have a CD-ROM on this machine?  

I tried building the anaconda SRPM, but it wants 
kudzu-devel >= 1.1.x, and I've only got 0.99 on my working
RH9 system. I guess I could update that...

Comment 8 Leonard den Ottolander 2004-05-03 17:48:52 EDT
If you boot from CD1 to "linux rescue" does the driver get loaded and
the nic set up correctly?

I don't understand comment #7, why would the installer ask for a
driver if you select a hd installation? Did it show a list of network
drivers or other drivers?

And how do you boot if you have no cdrom? Or do you mean just a cd-writer?
Comment 9 Jeremy Katz 2004-05-05 18:22:04 EDT

*** This bug has been marked as a duplicate of 120289 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:02:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.