Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1203872 - [abrt] vdsm-python: configurator.py:273:isconfigured:RuntimeError:
Summary: [abrt] vdsm-python: configurator.py:273:isconfigured:RuntimeError:
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: vdsm
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Federico Simoncelli
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:eea8f8495a9252053bbed0f4653...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 20:02 UTC by Тарасов Андрей
Modified: 2015-12-02 17:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-02 10:18:11 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.56 KB, text/plain)
2015-03-19 20:02 UTC, Тарасов Андрей
no flags Details
File: environ (169 bytes, text/plain)
2015-03-19 20:02 UTC, Тарасов Андрей
no flags Details

Description Тарасов Андрей 2015-03-19 20:02:04 UTC
Version-Release number of selected component:
vdsm-python-4.14.8.1-1.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python /usr/bin/vdsm-tool is-configured
executable:     /usr/bin/vdsm-tool
kernel:         3.18.8-201.fc21.x86_64
runlevel:       unknown
type:           Python
uid:            0

Truncated backtrace:
configurator.py:273:isconfigured:RuntimeError: 

One of the modules is not configured to work with VDSM.
To configure the module use the following:
'vdsm-tool configure [module_name]'.

If all modules are not configured try to use:
'vdsm-tool configure --force'
(The force flag will stop the module's service and start it
afterwards automatically to load the new configuration.)


Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 145, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 142, in main
    return tool_command[cmd]["command"](*args[1:])
  File "/usr/lib64/python2.7/site-packages/vdsm/tool/configurator.py", line 273, in isconfigured
    raise RuntimeError(msg)
RuntimeError: 

One of the modules is not configured to work with VDSM.
To configure the module use the following:
'vdsm-tool configure [module_name]'.

If all modules are not configured try to use:
'vdsm-tool configure --force'
(The force flag will stop the module's service and start it
afterwards automatically to load the new configuration.)


Local variables in innermost frame:
msg: "\n\nOne of the modules is not configured to work with VDSM.\nTo configure the module use the following:\n'vdsm-tool configure [module_name]'.\n\nIf all modules are not configured try to use:\n'vdsm-tool configure --force'\n(The force flag will stop the module's service and start it\nafterwards automatically to load the new configuration.)\n"
c: <vdsm.tool.configurator.SanlockModuleConfigure object at 0x7f748e83e7d0>
args: Namespace(modules=['libvirt', 'sanlock'])
m: ['libvirt']
ret: False

Potential duplicate: bug 1097356

Comment 1 Тарасов Андрей 2015-03-19 20:02:11 UTC
Created attachment 1004192 [details]
File: backtrace

Comment 2 Тарасов Андрей 2015-03-19 20:02:13 UTC
Created attachment 1004193 [details]
File: environ

Comment 3 Fedora End Of Life 2015-11-04 10:42:01 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2015-12-02 10:18:16 UTC
Fedora 21 changed to end-of-life (EOL) status on 2015-12-01. Fedora 21 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.