Bug 120398 - (NET B44) Problem optaining DHCP addresses for b44 netcard
Summary: (NET B44) Problem optaining DHCP addresses for b44 netcard
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-08 13:23 UTC by Anders Joergensen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 00:22:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anders Joergensen 2004-04-08 13:23:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
There seems to be a problem optaining DHCP IPv4 addresses for the
2.6.* kernels in the Fedora Core 2 Test1. Giving the machine a
permanent IPv4-address works fine.

The netcard that I have is
...
01:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T
(rev 01)
        Subsystem: Dell Computer Corporation: Unknown device 8127
        Flags: bus master, fast devsel, latency 64, IRQ 17
        Memory at fe9fe000 (32-bit, non-prefetchable) [size=8K]
        Expansion ROM at fea00000 [disabled] [size=16K]
        Capabilities: [40] Power Management version 2
...

The b44 module loads just fine, and I do get a "Link is up".

Version-Release number of selected component (if applicable):
kernel-smp-2.6.4-1.305

How reproducible:
Always

Steps to Reproduce:
1. Boot a system with a BCM4401 card in a network with a DHCP server
2.
3.
    

Actual Results:  Network startup, and getting a IP-address fails.

Expected Results:  Network startup and getting an IP-address succesfull.

Additional info:

I have searched the mailing lists without any results. Please contact
me if you want a tcpdump of a service network start, or ifup eth0.

Comment 1 David Juran 2004-05-18 15:35:21 UTC
Seems to me like this problem is fixed in the FC2 release, i.e. kernel
2.6.5-1.358. However in RHEL 3 U2, kernel 2.4.21-15.ELBOOT the same
problem exists.
Could we please move the product tag?

Comment 2 Arjan van de Ven 2004-05-18 15:36:25 UTC
David: please open a new bug instead; while the symptom might be the
same the cause most likely isn't and keeping the same bug for that
just makes things really confusing and messy.

Comment 3 David Juran 2004-05-19 12:16:42 UTC
Bug 123558 created. Also I think my it might be realted to bug 105787

Comment 4 Arjan van de Ven 2004-05-29 08:56:33 UTC
this bug should be fixed in the final release btw...


Note You need to log in before you can comment on or make changes to this bug.