Bug 120409 - modutils RPM's %obsoletes spec tag causing problems
modutils RPM's %obsoletes spec tag causing problems
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: modutils (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 11:02 EDT by Rick Mohr
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 12:38:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Mohr 2004-04-08 11:02:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
The "Obsoletes: modules" line in the modutils rpm is causing problems
when an rpm called "modules" (which is not related to kernel modules)
is installed.

My systems use a package called modules that is used for manipulating
a user's environment (http://modules.sourceforge.net).  This is
installed as an rpm by the same name.  However, the modutils spec file
contains a line that obsoletes modules, presumably an older version of
the kernel module related utilities which was packaged under the
modules name.

When running up2date, the program reported that modutils-2.4.25-11.EL
needed to be installed even though it already was.  If the modutils
package was included in the updates, the update process then failed
because it determined that modutils was already installed.  One work
around was to simply deselect the modutils update every time that I
ran up2date.  In an attempt to avoid doing this every time, I
re-installed the modutils rpm (thinking that perhaps the rpm database
had an error and that re-installing would force the proper information
into it).  This caused my installed modules rpm to be erased without
my knowledge.

There are really a couple of thing at work here (which might not
exactly make this a modutils bug):

1) modutils obsoletes a package that is not even part of RedHat's set
of packages to begin with.

2) rpm has no good way of distinguishing packages other than by name
with no regard to content or group.

3) rpm will erase an obsoleted package with absolutely no indication
or warning that it is doing so.

I am not sure what the best course of action is.  I could rename the
modules rpm I use, but that kind of defeats the point of having the
rpm package name match the software name.  But perhaps a better
temporary fix would be to remove the "Obsoletes" tag from the modutils
 rpm.  And a better long-term fix would be to modify rpm's handling of
obsoleted packages.

Version-Release number of selected component (if applicable):
modutils-2.4.25-11.EL

How reproducible:
Always

Steps to Reproduce:
1.Install any rpm package called "modules"
2.Install or upgrade the modutils rpm
3.
    

Actual Results:  The modules rpm will be erased.

Expected Results:  modules rpm should remain, or at least be warned
that is will be erased so that action can be aborted.

Additional info:
Comment 1 Bill Nottingham 2004-04-08 12:38:21 EDT
Removed for future builds.

It's going to break upgrades from RHL 4.2, though. :)

Will be in modutils-2.4.25-13.EL or later, if that's built.
Comment 2 Bill Nottingham 2004-04-08 12:38:36 EDT
Removed for future builds.

It's going to break upgrades from RHL 4.2, though. :)

Will be in modutils-2.4.25-13.EL or later, if that's built.

Note You need to log in before you can comment on or make changes to this bug.