Bug 120431 - Cannot customize package list
Summary: Cannot customize package list
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-08 19:17 UTC by Lee Olsen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 16:04:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lee Olsen 2004-04-08 19:17:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
I had XFree86 4.4.0 installed from source, and Fedora insisted on
"upgrading" to 4.3.0. To make things worse, the post-install script
for 4.3.0 fails trying to adjust /etc/X11/xkb. This kills the upgrade
mid stream, leaving what was Redhat 7.3 in an unbootable state.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start with a clean XFree86 4.2 system
2.rename /etc/X11/xkb (should be a directory)
3.ln -s /usr/X11R6/lib/X11/xkb /etc/X11/xkb (symlink pointing to self)
4.Install Fedora
    

Actual Results:  The install will abort, suggesting a media error,
when the real problem is a post-install error. If you could customize
the package list and skip the "upgrade" for X, this problem
disappears. It would also remove
the need to reinstall X 4.4.0

Additional info:

Comment 1 Jeremy Katz 2004-04-11 18:26:56 UTC
This is due to rpm not being able to handle directory/symlink
transitions... if you search, you'll find that bug.  There's not
really anything anaconda can do about it.

Comment 2 Lee Olsen 2004-04-11 21:52:13 UTC
That explains anaconda not being able to handle the post-install
failure, but the issue is letting the user customize the list.
I *KNOW* the 4.3.0 install will fail, I want to *SKIP THE INSTALL*
of 4.3.0. RedHat 7.3 has a "Customize" check box on the screen where
you choose the installation type (workstation/server/upgrade) and
Fedora needs that feature too. Recovery after a failed post-install
is *NOT* the issue.


Note You need to log in before you can comment on or make changes to this bug.