Bug 120454 - intltool's Makefile.in.in incompatible with automake-1.8
intltool's Makefile.in.in incompatible with automake-1.8
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: intltool (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 17:24 EDT by Pawel Salek
Modified: 2013-04-02 00:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 16:12:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2004-04-08 17:24:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
the Makefile.in.in file distributed with intltool assumes that
mkinstalldirs script is installed by automake. This is not generally
true. In particular, automake-1.8 does not install that file. This
assumption breaks install target of generated Makefile.

Version-Release number of selected component (if applicable):
intltool-0.30-1

How reproducible:
Always

Steps to Reproduce:
1. run automake-1.8 on any relevant project.
2. verify that mkinstalldirs script was not created.
3. try running "make install"

Actual Results:  Build will break in the translations directory (po)
with a message "mkinstalldirs: No such file or directory"

Expected Results:  project should be installed correctly.

Additional info:

A workaround it to install an older version of automake. automake-1.7
still creates this script. I usually use a very simple bootstrap.sh
script to bootstrap balsa module of gnome CVS and it can be used to
demonstrate the problem:

glib-gettextize --force --copy || exit 1
intltoolize --copy --force --automake
aclocal || exit 1
autoheader || exit 1
libtoolize --force || exit 1
automake --foreign --add-missing --copy
autoconf || exit 1
./configure "$@"
Comment 1 Mikko Paananen 2004-05-03 15:57:41 EDT
Gimp from cvs:
checking for intltool < 0.28 or > 0.31 ... no (found version 0.30)
                                                                     
          
  Versions of intltool between 0.28 and 0.31 are known to
  generate incorrect XML output.  Please consider using an
  earlier version of intltool in order to avoid these
  problems until a newer version of intltool is released.

Also, intltool-update -r fails because it tries to call
GetLanguageFromPOFile, instead of POFile_GetLanguage on line 774.

These bugs make current intltool useless. Unfortunately updated
intltool is not yet released, but when it is, update should be issued
A.S.A.P.
Comment 2 Jonathan Blandford 2004-05-03 16:08:44 EDT
Oh blah.  Lemme see if I can get a enew intltool into FC2.
Comment 3 Jonathan Blandford 2004-05-03 16:12:18 EDT
...looks like that fix is in CVS only, and a 0.31 hasn't been
released.    Not much I can do unless a new intltool is released shortly.

Note You need to log in before you can comment on or make changes to this bug.