Bug 120464 - Should document the 'C' field of rpm -V
Should document the 'C' field of rpm -V
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 145117 146662 147394 172789 175304 192615 194348 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 20:05 EDT by Derek Poon
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-07 17:14:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Poon 2004-04-08 20:05:59 EDT
Description of problem:
rpm man page says this about the output of rpm -V:
       S file Size differs
       M Mode differs (includes permissions and file type)
       5 MD5 sum differs
       D Device major/minor number mismatch
       L readLink(2) path mismatch
       U User ownership differs
       G Group ownership differs
       T mTime differs

But in recent versions of rpm, there are now nine fields.  The man
page should be updated to say something like:
       C SELinux file Context differs

Version-Release number of selected component (if applicable):
rpm-4.3.1-0.1

How reproducible:
Always

Steps to Reproduce:
1. rpm -V
2. man rpm
Comment 1 Jeff Johnson 2005-01-14 13:34:58 EST
*** Bug 145117 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Johnson 2005-02-02 10:56:07 EST
*** Bug 146662 has been marked as a duplicate of this bug. ***
Comment 3 Paul Nasrat 2005-02-07 16:01:03 EST
*** Bug 147394 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Johnson 2005-11-13 21:19:11 EST
*** Bug 172789 has been marked as a duplicate of this bug. ***
Comment 5 Aaron Sherman 2005-11-22 08:11:12 EST
I'd just like to follow up here, because my "duplicate" bug contained a bit more
detail (bug #172789).

This omission also affects the fedora documentation site.

In the FC4 version that I was looking at, the flag is generated at lib/verify.c
line 362.
Comment 8 Jeff Johnson 2005-12-22 00:45:03 EST
*** Bug 175304 has been marked as a duplicate of this bug. ***
Comment 9 Jeff Johnson 2006-05-29 08:33:51 EDT
*** Bug 192615 has been marked as a duplicate of this bug. ***
Comment 10 Jeff Johnson 2006-06-08 08:36:03 EDT
*** Bug 194348 has been marked as a duplicate of this bug. ***
Comment 11 Jeff Johnson 2006-07-07 17:14:43 EDT
rpm-4.4.7 no longer verifies selinux file contexts, hence no need to document.

Note You need to log in before you can comment on or make changes to this bug.