Bug 120477 - Something funny when installing policy*1.10.1-4
Something funny when installing policy*1.10.1-4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 01:17 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 08:29:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-04-09 01:17:14 EDT
Description of problem:

Running "rpm -Fvh policy*" resulted in the following output
from "rpm -qa --last 'policy*'":

policy-sources-1.10.1-4               Thu 08 Apr 2004 10:19:52 PM MDT
policy-1.10.1-4                       Thu 08 Apr 2004 04:23:58 PM MDT
policy-sources-1.9.2-12               Tue 06 Apr 2004 08:08:13 PM MDT
policycoreutils-1.9.2-1               Tue 06 Apr 2004 08:08:08 PM MDT

This after "rpm -Uvh --force policy-sources-1.10.1-4" which also
failed to rectify the situation.

I do not know if this releated to bug 120476 or not.

Version-Release number of selected component (if applicable):
policy-1.10.1-4
Comment 1 Daniel Walsh 2004-04-12 11:36:55 EDT
execute 
rpm -e policy-sources-1.10.1-4

Not sure how you got this.

Dan
Comment 2 Leonard den Ottolander 2004-05-11 04:43:49 EDT
This looks like an rpm error. Changing component.
Comment 3 Michal Jaegermann 2004-05-11 11:49:36 EDT
I do not think that this is an rpm error.  I believe now that
this is a side effect of bugs in package scripts as described
in bug 120476 (fixed in the meantime).  Unless you mean that
rpm aborting on a script problem an already partially performed
action is an error.
Comment 4 Leonard den Ottolander 2004-05-11 18:17:39 EDT
Ok. Reassiging to Dan and policy again.
Comment 5 Daniel Walsh 2004-05-21 08:29:55 EDT
Yes I believe RPM aborted before deleting the previous version.  This
might have been a side effect of a bad policy but It is not currently
repeatable and there have been numerous fixes since then.

So I am marking it closed in Rawhide.

Dan

Note You need to log in before you can comment on or make changes to this bug.