Bug 120482 - incorrect dependences in python part
incorrect dependences in python part
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 03:23 EDT by Grigory Bakunov
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-09 05:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grigory Bakunov 2004-04-09 03:23:37 EDT
Description of problem:
libxml2-python package doesn't depends on python version now.
But if you look in
black@dds> rpm -q libxml2-python -l|grep /python
/usr/lib/python2.3/site-packages/drv_libxml2.py
/usr/lib/python2.3/site-packages/libxml2.py
/usr/lib/python2.3/site-packages/libxml2mod.a
/usr/lib/python2.3/site-packages/libxml2mod.la
/usr/lib/python2.3/site-packages/libxml2mod.so
you'll see - realy libxml2-python package must be depended on python 
=> 2.3 and python < 2.4.


Version-Release number of selected component (if applicable):
libxml2-2.6.8-1

How reproducible:
Always
Comment 1 Daniel Veillard 2004-04-09 05:54:33 EDT
Makes sense, I commited a fix to the spec file in GNOME CVS
and tested it in RHL 9, FC1 and FC2b2.
This doesn't seems urgent, so this will propagate with the next
release of libxml2 , i.e. when 2.6.9 ships, probably within a few
weeks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.