Bug 120490 - SCSI generic support (sg.ko) missing from kernel
SCSI generic support (sg.ko) missing from kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 07:57 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 08:32:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2004-04-09 07:57:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
The SCSI generic module (sg.ko) is missing since kernel-2.6.4-1.302,
it is disabled in the kernel config. It was present (and working) in
earlier kernel releases.

This makes CD burning on SCSI-CDR drives somewhat difficult.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.309

How reproducible:
Always

Steps to Reproduce:
1. modprobe sg
2.
3.
    

Actual Results:  No such module

Expected Results:  Loading of the module

Additional info:
Comment 1 Arjan van de Ven 2004-04-09 08:42:55 EDT
ehhh why would it make it difficult?
just do 
cdrecord --dev=/dev/scd0 

sg is deprecated functionaly (just like ide-scsi is)
Comment 2 Ralf Ertzinger 2004-04-09 13:10:46 EDT
So, if sg is going away, how am I going to talk to my tape changer,
for example?

Anyway, cdrecord needs a whack on the head to cope with sg being
absent, -scanbus does not work at all.
I'm filing a new bug for that.
Comment 3 Arjan van de Ven 2004-04-09 13:14:06 EDT
you use SG_IO ioctl on the device directly...

oh the good news is that -scanbus no longer is needed since you can
talk to the device directly; no need to find weird mappings to it via
scanbus...
Comment 4 Ralf Ertzinger 2004-04-09 14:33:09 EDT
OK, I can see that scanbus is quite obsolete.

But AFAIR tape changers consist of at least two SCSI devices (each
with a seperate ID, at least one for the tape(s), and at least one for
the changer(s) itself).

While the tapes do get a device (/dev/st...), the changers I have seen
so far under 2.4 only get a /dev/sg... device node.

Maybe there is a node to use in /sysfs for the changers, too, I do not
know.

But if not: which device do I use the SG_IO ioctls on?
Comment 5 Arjan van de Ven 2004-04-16 04:58:47 EDT
added sg back in rawhide for your tape changer. Please test
Comment 6 Ralf Ertzinger 2004-04-17 12:47:08 EDT
Sorry for the confusion.
I currently do not have a tape changer to test 2.6 on. My comment
above on the sg module was to remind that more devices besides CD
recorders might be affected by this.

Also see the man page for mtx (shipped by FC).
Comment 7 Alan Cox 2004-05-03 08:32:27 EDT
Present in 327 kernel, seems ok on minimal testing

Note You need to log in before you can comment on or make changes to this bug.