Bug 120502 - 2.1U4 beta: Kudzu & anaconda load different ethernet drivers
2.1U4 beta: Kudzu & anaconda load different ethernet drivers
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 11:36 EDT by Wendy Hung
Modified: 2013-08-05 21:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 16:16:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci of x205 without any adapters installed (1.02 KB, text/plain)
2004-04-15 15:09 EDT, Wendy Hung
no flags Details
lspci with adapters installed (1.42 KB, text/plain)
2004-04-15 15:11 EDT, Wendy Hung
no flags Details

  None (edit)
Description Wendy Hung 2004-04-09 11:36:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
H010818)

Description of problem:
Red Hat 2.1 AS Update 4 beta re0311 loads different device drivers 
for the Intel 10/100 Ethernet Server Adapter and the Intel Pro/1000 
XT adapter when Kudzu is used as opposed to an OS install.   

Is this expected behavior?

  








Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 10/100 and Pro/1000 XT adapters in valid slot on a Server
2. Install RH AS 2.1 Update 4 (Beta re0311) and allow anaconda to 
configure the adapters. 
4. When the OS comes up, run lsmod command; note that e1000 and 
eepro100 are used.
5. Turn machine off and remove adapters.
6. Install OS and shutdown after install.
7. Install the same 10/100 and Pro/1000 XT adapters
8. Use Kudzu to configure adapters.
9. Run lsmod command and note e100_2124k2 and e1000_5043k1 are used.

Actual Results:  If 10/100 and Pro/1000 XT adapters are physically 
installed in a server,  anaconda loads the e1000 and eepro100 
drivers.   If the same adapters are added post-install and configured 
with kudzu, the e100_2124k2 and e1000_5043k1 device drivers are 
loaded instead. 



Expected Results:  The same drivers would be loaded using anaconda or 
kudzu.

Additional info:
Comment 1 Bill Nottingham 2004-04-13 00:21:13 EDT
lspci?
Comment 2 Bill Nottingham 2004-04-13 00:47:19 EDT
e100_2124k2 and e1000_5043k1 have subsystem/subdevice IDs, eepro100
and e1000 don't.

kudzu takes the most exact match from modules.pcimap.
Comment 3 Wendy Hung 2004-04-15 15:09:19 EDT
Created attachment 99453 [details]
lspci of x205 without any adapters installed
Comment 4 Wendy Hung 2004-04-15 15:11:22 EDT
Created attachment 99454 [details]
lspci with adapters installed

Machine was shutdown and an Intel Pro/1000 XT adapter inserted in Slot 1, a 1
port Intel 10/100 adapter inserted in Slot 2 and a dual port Intel 10/100
adapter inserted in Slot 3.   The machine was powered up and all the ports were
recognized by Kudzu and each was configured via Kudzu.
Comment 5 Wendy Hung 2004-04-15 15:12:35 EDT
With the adapters installed, lsmod command was run which shows the 
issue:
Module                  Size  Used by    Not tainted
ide-cd                 35200   0  (autoclean)
cdrom                  35168   0  (autoclean) [ide-cd]
i810_audio             26752   0  (autoclean)
ac97_codec             14816   0  (autoclean) [i810_audio]
soundcore               7364   2  (autoclean) [i810_audio]
autofs                 13220   0  (autoclean) (unused)
e100_2124k2            65240   3 
e1000_5043k1           60216   1 
tg3                    49248   0 
usb-uhci               25540   0  (unused)
usbcore                65440   1  [usb-uhci]
ext3                   67872   2 
jbd                    51560   2  [ext3]
aic7xxx               126944   3 
sd_mod                 13856   3 
scsi_mod              123264   2  [aic7xxx sd_mod]
Comment 6 Wendy Hung 2004-06-03 14:18:43 EDT
Tried something similar with RHAS2.1 Update4 (Gold)
1. Installed RHAS2.1 Update4 Gold code with no cards installed
2. After successful install, powered machine off
3. Inserted Pro 1000 XT and 10/100 Intel Adapapters
4. Turned machine on, ran kudzu which picked up
   and configured both adapters
5. After boot finished lsmod showed eepro100
   and e1000_5043k1 drivers
Comment 7 Wendy Hung 2004-09-09 16:05:27 EDT
This can still be reproduced with RHEL 2.1 U5 Gold code.
Is this considered a bug or working as designed?
Comment 8 Wendy Hung 2004-09-29 11:09:37 EDT
Do you need any more information to update modules.pcimap so that 
kudzu will load the same driver?  or are there no plans to fix this 
in Update 6?
Comment 9 Jim Paradis 2006-09-14 16:16:12 EDT
Since this issue is beyond the scope of the current support status of RHEL2.1, I
am closing it as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.