Bug 120510 - OpenOffice build may fail because of %kill_xdisplay execution
Summary: OpenOffice build may fail because of %kill_xdisplay execution
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-09 17:57 UTC by Jos Vos
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-10 18:40:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Vos 2004-04-09 17:57:35 UTC
Description of problem:
When I tweaked around with restarting/reconfiguring X11 during a rpm
build of openoffice, the build finally (...) failed with:

+ cat /tmp/.X0-lock
+ kill 26099
/var/tmp/rpm-tmp.60438: line 124: kill: (26099) - Operation not permitted

When I checked the pid, it was the pid of the just (as root) started X
server.

Version-Release number of selected component (if applicable):
1.0.2-8

Comment 1 Dan Williams 2004-04-10 18:39:55 UTC
Unfortunately, OOo versions < 1.1.0 require an X connection to build.  This was 
supposed to be achieve by using Xvfb to fake an X server.  In any case, RHEL3 U2 will 
include OOo 1.1.0 which will not have this problem.  I'm going to close this as wontfix 
due to that exact reason, that it will soon not be an issue.  If you don't think that's 
right, please re-open the bug.

Thanks!

Comment 2 Dan Williams 2004-04-10 18:40:17 UTC
closing...


Note You need to log in before you can comment on or make changes to this bug.