This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 120533 - ifup starts multiple dhclient's
ifup starts multiple dhclient's
Status: CLOSED DUPLICATE of bug 120531
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 19:33 EDT by Nickolai Zeldovich
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nickolai Zeldovich 2004-04-09 19:33:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
When ifup is ran multiple times, multiple copies of dhclient are
started.  This is exacerbated by a DHCP server that takes a long time
to reply -- this means that the race condition window between ifup
doing a kill on the old dhclient, and the new dhclient writing out the
/var/run/pid file upon getting a lease, is quite large.

The attached patch uses /usr/bin/lockfile to do strict locking to
avoid the possibility of concurrently running dhclient processes
altogether.

Version-Release number of selected component (if applicable):
initscripts-7.49-1

How reproducible:
Always

Steps to Reproduce:
1.Run /sbin/ifup eth0 &
2.Run /sbin/ifup eth0
3.Notice two dhclient's running that don't exit
    

Actual Results:  As a result of having two dhclient processes running,
each process obtains a different DHCP lease and reconfigures the
interface according to _its_ lease periodically.

Additional info:
Comment 1 Nickolai Zeldovich 2004-04-09 19:35:29 EDT
Sigh, forgot to close the browser window, and accidentally re-posted
the bug from Mozilla.  Sorry.  This is a duplicate is 120531.
Comment 2 Miloslav Trmac 2004-04-12 06:07:54 EDT

*** This bug has been marked as a duplicate of 120531 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:02:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.