Bug 120557 - Configuration error for Samba printer
Configuration error for Samba printer
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Depends On:
  Show dependency treegraph
Reported: 2004-04-10 15:21 EDT by Fred New
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.11.3-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-05-10 14:03:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
relevant /var/log/messages (2.39 KB, text/plain)
2004-04-13 14:34 EDT, Fred New
no flags Details
More /var/log/messages (2.13 KB, text/plain)
2004-04-14 17:05 EDT, Fred New
no flags Details
tail -18 /var/log/messages (4.09 KB, text/plain)
2004-05-02 05:50 EDT, Fred New
no flags Details

  None (edit)
Description Fred New 2004-04-10 15:21:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
My LaserJet 4L printer is attached to a Windows XP system.  I have
configured this printer through system-config-printer on my FC2T2
system, but it doesn't print the CUPS test page.  I don't have the smb
service started.  Here may be some other clues:

# lpstat -t
scheduler is running
system default destination: LJ4L
device for LJ4L: smb://NOISY/LJ4L
LJ4L accepting requests since Jan 01 00:00
printer LJ4L disabled since Jan 01 00:00 -
        Can't load /etc/samba/smb.conf - run testparm to debug it
LJ4L-10                 root             15360   Sat 10 Apr 2004
09:40:26 PM EEST
# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Loaded services file OK.
Press enter to see a dump of your service definitions
# Global parameters
        workgroup = HOME
        server string = Samba Server
        password server = None
        username map = /etc/samba/smbusers
        log file = /var/log/samba/%m.log
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        dns proxy = No
        comment = Home Directories
        read only = No
        browseable = No
        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Configure a remote Samba printer using system-config-printer.
2. Attempt to print the CUPS test page.


Actual Results:  No printing and the above lpstat messages.

Expected Results:  A successful page printed on my printer.

Additional info:

I have tried printing the test page with "setenforce 0", but the
results are the same.

This printer configuration worked a few days ago on this same system
(FC2T2).  At that time, I had to "setenforce 0" to get it to work.
Comment 1 Fred New 2004-04-13 14:34:33 EDT
Created attachment 99377 [details]
relevant /var/log/messages

I am changing this to a policy bug.  It appears that the policy isn't
permitting system-config-printer to configure the printer correctly.  My
currently policy version is
Comment 2 Fred New 2004-04-14 17:05:53 EDT
Created attachment 99430 [details]
More /var/log/messages

I have policy-1.11.2-3 installed now.  The test page from
system-config-printers prints and the messages from "lpstat -t" appear correct.
 But the attached messages appear in /var/log/messages.  I don't know if you
need to address them or not.
Comment 3 Daniel Walsh 2004-04-22 15:17:38 EDT
Fixed in policy-1.11.2-17
Comment 4 Fred New 2004-05-02 05:50:45 EDT
Created attachment 99872 [details]
tail -18 /var/log/messages

With policy-1.11.2-18 I see these messages when printing a CUPS test page
(enforcing mode).  The page prints successfully.
Comment 5 Fred New 2004-05-02 06:59:21 EDT
With policy-1.11.2-21, I only get one message in enforcing mode:
May  2 14:00:50 kuldar kernel: audit(1083495650.774:0): avc:  denied 
{ read } for  pid=1884 exe=/usr/bin/lpr.cups
path=/var/run/sudo/user_u/unknown:root dev=hda3 ino=178439
tcontext=user_u:object_r:pam_var_run_t tclass=file
Comment 6 Fred New 2004-05-09 13:06:08 EDT
Fixed with policy-1.11.3-3.

Note You need to log in before you can comment on or make changes to this bug.