Bug 120578 - Microcode CPU Update does not apply
Microcode CPU Update does not apply
Status: CLOSED DUPLICATE of bug 120603
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-11 02:52 EDT by Rainer Traut
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Traut 2004-04-11 02:52:57 EDT
Description of problem:
It's an U1 machine, Dell PE2650 Server, single XEON, 2GB Ram
Applied from U2 Beta are the following Updates:
Kernel, glibc nptl and shadow utils.

When running micrcode update I get kernel error messages.

[root@asp3 root]# service microcode_ctl start
Applying Intel IA32 Microcode update:                      [  OK  ]
[root@asp3 root]# dmesg
...
microcode: error! Bad data in microcode data file
microcode: Error in the microcode data
[root@asp3 root]# md5sum /etc/firmware/microcode.dat
538e094b95a6e27fd561bb3ad8b49831  /etc/firmware/microcode.dat
[root@asp3 root]# 

Version-Release number of selected component (if applicable):

[root@asp3 root]# rpm -qa|grep kernel-utils
kernel-utils-2.4-8.37.1
[root@asp3 root]# lspci
00:00.0 Host bridge: ServerWorks CNB20-HE Host Bridge (rev 33)
00:00.1 Host bridge: ServerWorks CNB20-HE Host Bridge
00:00.2 Host bridge: ServerWorks CNB20-HE Host Bridge
00:04.0 Class ff00: Dell Computer Corporation Remote Access
Controller:ERA or ERA/O
00:04.1 Class ff00: Dell Computer Corporation Remote Access Controller
00:04.2 Class ff00: Dell Computer Corporation BMC/SMIC device
00:0e.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
00:0f.0 Host bridge: ServerWorks CSB5 South Bridge (rev 93)
00:0f.1 IDE interface: ServerWorks CSB5 IDE Controller (rev 93)
00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 05)
00:0f.3 ISA bridge: ServerWorks GCLE Host Bridge
00:10.0 Host bridge: ServerWorks: Unknown device 0101 (rev 05)
00:10.2 Host bridge: ServerWorks: Unknown device 0101 (rev 05)
00:11.0 Host bridge: ServerWorks: Unknown device 0101 (rev 05)
00:11.2 Host bridge: ServerWorks: Unknown device 0101 (rev 05)
01:06.0 RAID bus controller: LSI Logic / Symbios Logic PowerEdge
Expandable RAID Controller 4 (rev 01)
03:06.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5703
Gigabit Ethernet (rev 02)
03:08.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5703
Gigabit Ethernet (rev 02)
04:08.0 PCI bridge: Intel Corp.: Unknown device 0309 (rev 01)
05:06.0 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
05:06.1 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
[root@asp3 root]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) CPU 2.40GHz
stepping        : 9
cpu MHz         : 2390.188
cache size      : 512 KB
physical id     : 0
siblings        : 2
runqueue        : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 4771.02

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) CPU 2.40GHz
stepping        : 9
cpu MHz         : 2390.188
cache size      : 512 KB
physical id     : 0
siblings        : 2
runqueue        : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 4771.02

[root@asp3 root]# 

How reproducible:


Steps to Reproduce:
1. Boot
2. see Microcode update run
3. see dmesg output
  
Actual results:
microcode: error! Bad data in microcode data file
microcode: Error in the microcode data

Expected results:
Silence

Additional info:
Comment 1 Rainer Traut 2004-04-11 03:10:16 EDT
Forgot:
[root@asp3 root]# uname -a
Linux asp3.awaro.com 2.4.21-13.ELsmp #1 SMP Wed Apr 7 22:49:22 EDT
2004 i686 i686 i386 GNU/Linux
[root@asp3 root]#
Comment 3 Bill Nottingham 2004-04-19 16:01:34 EDT

*** This bug has been marked as a duplicate of 120603 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.