Bug 120584 - kudzu wants to remove & add PCI wireless card on every boot
kudzu wants to remove & add PCI wireless card on every boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-11 09:10 EDT by Robert de Rooy
Modified: 2014-03-16 22:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 15:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hwconf after I told kudzu to ignore further add/remove messages for the wireless card (5.33 KB, text/plain)
2004-04-11 09:13 EDT, Robert de Rooy
no flags Details

  None (edit)
Description Robert de Rooy 2004-04-11 09:10:39 EDT
Description of problem:

IBM ThinkPad T30 with integrated MiniPCI wireless card
kudzu gives a message on boot that the wireless card is missing,
asking if I want to remove the configuration from the system.
Immediately after that it gives a message that a wireless card has
been detected, giving me the option to configure it.

Version-Release number of selected component (if applicable):

Same thing happened with Fedora Core 2 Test 1

[root@tderooy root]# rpm -q kudzu
kudzu-1.1.54-1

How reproducible:

every time, as long as kudzu is enabled.

Steps to Reproduce:
1. Boot T30 with FC2T1 or FC2T2
2.
3.
  
Actual results:


Expected results:


Additional info:

[root@tderooy root]# kudzu -p -c network
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: e100
desc: "Intel Corp.|82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller"
network.hwaddr: 00:09:6B:50:5A:B8
vendorId: 8086
deviceId: 1031
subVendorId: 1014
subDeviceId: 0209
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  8
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth2
driver: orinoco_pci
desc: "Harris Semiconductor|Prism 2.5 Wavelan chipset"
vendorId: 1260
deviceId: 3873
subVendorId: 8086
subDeviceId: 2513
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  2
pcifn:  0

[root@tderooy root]# lspci -vvs 02:02
02:02.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan
chipset (rev 01)
        Subsystem: Intel Corp. Wireless 802.11b MiniPCI Adapter
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at f8000000 (32-bit, prefetchable)
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Comment 1 Robert de Rooy 2004-04-11 09:13:56 EDT
Created attachment 99311 [details]
hwconf after I told kudzu to ignore further add/remove messages for the wireless card
Comment 2 Bill Nottingham 2004-04-13 00:15:25 EDT
If it's in the state where it's warning you, can you run a diff on
'kudzu -p' and /etc/sysconfig/hwconf?
Comment 3 Robert de Rooy 2004-04-18 14:55:53 EDT
Just upgraded to kudzu-1.1.56-1

[root@tderooy sysconfig]# kudzu -p -c NETWORK
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: e100
desc: "Intel Corp.|82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller"
network.hwaddr: 00:09:6B:50:5A:B8
vendorId: 8086
deviceId: 1031
subVendorId: 1014
subDeviceId: 0209
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  8
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth2
driver: orinoco_pci
desc: "Intersil Corporation|Prism 2.5 Wavelan chipset"
vendorId: 1260
deviceId: 3873
subVendorId: 8086
subDeviceId: 2513
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  2
pcifn:  0

As you can see from the earlier attachment where I told it to ignore
the removed and re-detected adapter. The Hermes entry is there twice
with the same data. the only difference is that once it is eth1 and
the other time it is eth2.
This system really does not have two wireless PCI cards on the same
PCI ID.
During normal system usage the wireless is eth1, as it should be.

Could it be that the wireless driver is getting loaded before kudzu
and so eth1 is already in use. Then kudzu detects the adapter and only
eth2 is available and it gets confused?

[root@tderooy sysconfig]# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:09:6B:50:5A:B8
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:308 (308.0 b)
 
eth1      Link encap:Ethernet  HWaddr 00:05:3C:03:FB:D0
          inet addr:192.168.1.254  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::205:3cff:fe03:fbd0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19853 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8611 errors:5 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15400049 (14.6 Mb)  TX bytes:1706278 (1.6 Mb)
          Interrupt:11 Base address:0x2000 Memory:f8000000-f8000fff
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1997 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1997 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2068962 (1.9 Mb)  TX bytes:2068962 (1.9 Mb)
 
sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
Comment 4 David Eriksson 2004-05-21 07:58:35 EDT
I have exactly the same problem with a fresh install of Fedora Core 2
(kudzu 1.1.36.1-1) on my Thinkpad T30. I did not have this problem on
my previous RedHat 9 installation.

Information about my hardware here: http://www.2good.nu/thinkpad_t30_fc2/
Comment 5 Alex Hudson (Fedora Address) 2004-07-13 04:59:15 EDT
Kudzu does exactly the same for me - I have a Prism54 PCI card, which
is detected fine, but every boot it asks to remove it since it thinks
the hardware is gone.

The diff of kudzu -p and /etc/sysconfig/hwconf shows that the hwconf
has a number of entries for the same card (with different ethX
devices, some of which also have detached: 1 set). I removed all the
entries except for eth2 - although my wireless PCI card is actually
eth0 in practice, 'kudzu -p' thinks it is eth2. Rebooting, kudzu no
longer complains. 

I did previously have a wired network card as eth0, and eth1 is a
forcedeth device on my motherboard. Old eth0 was removed via kudzu,
eth1 was detected on upgrade to core2 before the addition of the
wireless card. 
Comment 6 Robert de Rooy 2004-07-15 07:09:56 EDT
Kudzu 1.1.72-1 as part of FC3T1 still has the same issue
Comment 7 Bill Nottingham 2004-08-27 18:47:57 EDT
Please try the test rpms at:

http://people.redhat.com/notting/kudzu/
Comment 8 Robert de Rooy 2004-09-22 13:23:44 EDT
I am not able to recreate the problem with FC3T2, so the issue appears
to be resolved.

Note You need to log in before you can comment on or make changes to this bug.