Bug 120594 - ifconfig reports TX packets:0
ifconfig reports TX packets:0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-tools (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-11 14:39 EDT by James Armstrong
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.21-15.EL
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 01:15:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (5.63 KB, text/plain)
2004-04-14 17:56 EDT, James Armstrong
no flags Details

  None (edit)
Description James Armstrong 2004-04-11 14:39:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
ifconfig reports no packets have been sent on an active interface.

Version-Release number of selected component (if applicable):
net-tools 1.60

How reproducible:
Always

Steps to Reproduce:
0. Veiw web pages from and log in via ssh on system.
1. Enter /sbin/ifconfig
    

Actual Results:  TX packets:0

Expected Results:  TX packets:<more than 0>

Additional info:

set | grep SSH
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SSH_CLIENT='192.168.0.3 3657 22'
SSH_CONNECTION='192.168.0.3 3657 192.168.0.8 22'
SSH_TTY=/dev/pts/0

/sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:BF:96:3D:59  
          inet addr:192.168.0.8  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:173659 errors:2 dropped:0 overruns:0 frame:2
          TX packets:0 errors:177275 dropped:0 overruns:0 carrier:354327
          collisions:0 txqueuelen:1000 
          RX bytes:25275408 (24.1 Mb)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xd000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:247257 errors:0 dropped:0 overruns:0 frame:0
          TX packets:247257 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:25575298 (24.3 Mb)  TX bytes:25575298 (24.3 Mb)

snmpwalk -v2c -c private vaal if
IF-MIB::ifIndex.1 = INTEGER: 1
IF-MIB::ifIndex.2 = INTEGER: 2
IF-MIB::ifDescr.1 = STRING: lo
IF-MIB::ifDescr.2 = STRING: eth0
IF-MIB::ifType.1 = INTEGER: softwareLoopback(24)
IF-MIB::ifType.2 = INTEGER: ethernetCsmacd(6)
IF-MIB::ifMtu.1 = INTEGER: 16436
IF-MIB::ifMtu.2 = INTEGER: 1500
IF-MIB::ifSpeed.1 = Gauge32: 10000000
IF-MIB::ifSpeed.2 = Gauge32: 10000000
IF-MIB::ifPhysAddress.1 = STRING: 
IF-MIB::ifPhysAddress.2 = STRING: 0:50:bf:96:3d:59
IF-MIB::ifAdminStatus.1 = INTEGER: up(1)
IF-MIB::ifAdminStatus.2 = INTEGER: up(1)
IF-MIB::ifOperStatus.1 = INTEGER: up(1)
IF-MIB::ifOperStatus.2 = INTEGER: up(1)
IF-MIB::ifInOctets.1 = Counter32: 25624514
IF-MIB::ifInOctets.2 = Counter32: 25333942
IF-MIB::ifInUcastPkts.1 = Counter32: 247753
IF-MIB::ifInUcastPkts.2 = Counter32: 174414
IF-MIB::ifInDiscards.1 = Counter32: 0
IF-MIB::ifInDiscards.2 = Counter32: 0
IF-MIB::ifInErrors.1 = Counter32: 0
IF-MIB::ifInErrors.2 = Counter32: 2
IF-MIB::ifOutOctets.1 = Counter32: 25625716
IF-MIB::ifOutOctets.2 = Counter32: 0
IF-MIB::ifOutUcastPkts.1 = Counter32: 247769
IF-MIB::ifOutUcastPkts.2 = Counter32: 0
IF-MIB::ifOutDiscards.1 = Counter32: 0
IF-MIB::ifOutDiscards.2 = Counter32: 0
IF-MIB::ifOutErrors.1 = Counter32: 0
IF-MIB::ifOutErrors.2 = Counter32: 178144
IF-MIB::ifOutQLen.1 = Gauge32: 0
IF-MIB::ifOutQLen.2 = Gauge32: 0
IF-MIB::ifSpecific.1 = OID: SNMPv2-SMI::zeroDotZero
IF-MIB::ifSpecific.2 = OID: SNMPv2-SMI::zeroDotZero
cat /proc/version
Linux version 2.4.21-9.0.1.EL (bhcompile@bugs.devel.redhat.com) (gcc
version 3.2.3 20030502 (Red Hat Linux 3.2.3-26)) #1 Mon Feb 9 22:26:52
EST 2004
rpm -qa | grep net-tools
net-tools-1.60-20
/sbin/ifconfig -version
net-tools 1.60
ifconfig 1.42 (2001-04-13)
Comment 1 Phil Knirsch 2004-04-13 09:37:46 EDT
This sounds more like a driver problem reporting the statistics in a
wrong field.

Could you run

/sbin/lspci -v

on that machine please and post the output here?

Thanks,

Read ya, Phil
Comment 2 James Armstrong 2004-04-14 17:56:23 EDT
Created attachment 99432 [details]
lspci output
Comment 3 James Armstrong 2004-04-14 18:04:04 EDT
In case you're wondering, I had to add a NIC card to the system
since Linux could not see the integrated nForce2 device, so the
driver in use is for the Linksys Network Everywhere Fast Ethernet.
Comment 4 James Armstrong 2004-05-27 01:15:56 EDT
I've re-rested this on 2.4.21-15.EL and it works OK now.

Note You need to log in before you can comment on or make changes to this bug.