Bug 120600 - X11 dependencies in a textmode browser
X11 dependencies in a textmode browser
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: w3m (Show other bugs)
2
All Linux
medium Severity low
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-11 17:04 EDT by Daniel Roesen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-12 05:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Roesen 2004-04-11 17:04:12 EDT
It's kinda ironic to be unable to install a textmode web
browser on a non-X11 server:

# rpm -i w3m-0.4.1-8.i386.rpm
warning: w3m-0.4.1-8.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        ImageMagick is needed by w3m-0.4.1-8
        libgdk-1.2.so.0 is needed by w3m-0.4.1-8
        libgdk_pixbuf.so.2 is needed by w3m-0.4.1-8
        libgdk_pixbuf_xlib.so.2 is needed by w3m-0.4.1-8
        libgtk-1.2.so.0 is needed by w3m-0.4.1-8

Could we please have w3m trimmed down to _textmode_? :-)

Best regards,
Daniel
Comment 1 Akira TAGOH 2004-04-11 21:21:16 EDT
because of w3mimgdisplay depends on X. it will be separated.
Comment 2 Akira TAGOH 2004-04-12 05:10:46 EDT
Fixed in 0.5-2. you will have to install w3m-img as well if you want
to display the inline images on w3m.
Comment 3 Daniel Roesen 2004-04-12 07:54:19 EDT
Cool, thanks. Will test the new package as soon as it appears on
the FTP servers.
Comment 4 Daniel Roesen 2004-04-12 08:04:56 EDT
ah.. it's already there. Base package is working fine as far as I can see.
Comment 5 John Thacker 2005-01-12 21:39:23 EST
This seems to have reverted in the new 0.5.1-4.FC3.0 package that just got
pushed to FC3 updates-released.  w3mimgdisplay is back in the main package, and
the gtk dependencies are back.
Comment 6 Akira TAGOH 2005-01-13 01:45:17 EST
doh! will fix it soon. thanks!

Note You need to log in before you can comment on or make changes to this bug.