Bug 120638 - e100 problems with 2.4.21-9.0.1.ELsmp
e100 problems with 2.4.21-9.0.1.ELsmp
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-12 11:41 EDT by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 16:04:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-04-12 11:41:24 EDT
Description of problem:
Have supermicro p3tddr with on board ethernet. Prior kernel system 
works fine.  With 2.4.21-9.0.1.ELsmp Ethernet fails to initialize.
Get the following in the logs:
----------------------------
Apr 12 08:14:13 localhost kernel: e100: selftest timeout
Apr 12 08:14:13 localhost kernel: e100: Failed to initialize, 
instance #0
Apr 12 08:14:13 localhost kernel: e100: selftest timeout
Apr 12 08:14:13 localhost kernel: e100: Failed to initialize, 
instance #0
Apr 12 08:14:13 localhost kernel: Intel(R) PRO/100 Network Driver - 
version 2.3.
30-k1
Apr 12 08:14:13 localhost kernel: Copyright (c) 2003 Intel 
Corporation
Apr 12 08:14:13 localhost kernel: 
Apr 12 08:14:13 localhost kernel: e100: selftest timeout
Apr 12 08:14:13 localhost kernel: e100: Failed to initialize, 
instance #0
Apr 12 08:14:13 localhost kernel: e100: selftest timeout
Apr 12 08:14:13 localhost kernel: e100: Failed to initialize, 
instance #0
--------------------
Problem occurs on two seperate systems.  Both systems are the same 
type.  Using 2.4.21-4.ELsmp doesn't have the problem.  After logging 
in, it's sometimes possible to bring the ethernet up by trying:
ifconfig down, ifconfig up (repeat)...
-Release number of selected component (if applicable):


How reproducible:
Always.  
Steps to Reproduce:
1.Boot with 2.4.21-9.0.1.ELsmp as the kernel
2.
3.
  
Actual results:
e100 fails to initialize

Expected results:
e100 to initialize

Additional info:
Comment 1 Need Real Name 2004-04-19 11:15:31 EDT
I'm not entirely sure this is a redhat problem.I've also started 
having problems with 2.4.21-4.ELsmp and ethernet.  
Comment 2 rob lojek 2004-07-08 13:31:03 EDT
I opened bug 127407 because I'm seeing these messages with eepro on
kernel-smp-2.4.21-9.0.1.EL:

eth0: can't fill rx buffer (force 0)!

I tried to load up the e100 driver instead, but


[root@nlbuild02 root]# lspci |grep -i eth
00:0e.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 08)

according to pcitable, e100 is the default driver:

[root@opus hwdata]# grep '82557/8/9 \[Ethernet P'
/usr/share/hwdata/pcitable
0x8086  0x1229  "e100"  "Intel Corp.|82557/8/9 [Ethernet Pro 100]"


however, I can't load e100:

# modprobe e100
/lib/modules/2.4.21-9.0.1.ELsmp/kernel/drivers/net/e100/e100.o:
init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.21-9.0.1.ELsmp/kernel/drivers/net/e100/e100.o: insmod
/lib/modules/2.4.21-9.0.1.ELsmp/kernel/drivers/net/e100/e100.o failed
/lib/modules/2.4.21-9.0.1.ELsmp/kernel/drivers/net/e100/e100.o: insmod
e100 failed


Any ideas?
Comment 3 John W. Linville 2004-08-23 16:14:41 EDT
Probably need to attach a full lspci -vvn (at least for 0:e.0)...

Is this still an issue w/ the later RHEL3 updates?
Comment 4 John W. Linville 2004-10-12 16:04:01 EDT
The e100 driver has had many updates since this problem was reported.
 Please reopen this bug if the problem still occurs w/ 3.0.27-k2 or later.

Note You need to log in before you can comment on or make changes to this bug.