Bug 120643 - kudzu causes kernel errors(REPRODUCEABLE)
kudzu causes kernel errors(REPRODUCEABLE)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-12 12:54 EDT by Sean Bruno
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 00:12:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f of kudzu at system boot (100.24 KB, text/plain)
2004-04-12 12:56 EDT, Sean Bruno
no flags Details

  None (edit)
Description Sean Bruno 2004-04-12 12:54:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I have been troubleshooting issues with kudzu and my 802.11g wireless
PCI card(using madwifi drivers).

When the system starts, kudzu will hang the entire system if it runs
before the network devices are started(sounds a lot like the recent
problems with the 3com drivers).

But what is even stranger, if I start kudzu last(change the init
script from S05kudzu to S99kudzu), the system will not hang and boot
normally.  This is not the desired place for kudzu to start as it
needs to be able to setup new hardware prior to the rest of the system
starting.  But it is a viable work-around for now.

I am attaching the strace -f of kudzu at boot time for your reading
enjoyment.

Even worse than the above issues, is if I delete the entries from
/etc/modprobe.conf and the /etc/sysconfig/network-scripts/ifcfg-eth0.
Then I get this kernel error message:

Apr 11 21:17:11 localhost kernel: ------------[ cut here ]------------
Apr 11 21:17:11 localhost kernel: kernel BUG at fs/proc/generic.c:660!
Apr 11 21:17:11 localhost kernel: invalid operand: 0000 [#1]
Apr 11 21:17:11 localhost kernel: CPU:    0
Apr 11 21:17:11 localhost kernel: EIP:    0060:[<0219c223>]    Tainted: P
Apr 11 21:17:11 localhost kernel: EFLAGS: 00010202   (2.6.5-1.315)
Apr 11 21:17:11 localhost kernel: EIP is at remove_proc_entry+0xa5/0xf6
Apr 11 21:17:11 localhost kernel: eax: 00000001   ebx: 17dba9cc   ecx:
00000000   edx: 21fde880
Apr 11 21:17:11 localhost kernel: esi: 21fde8b0   edi: 17d67800   ebp:
00000005   esp: 17f6fee0
Apr 11 21:17:11 localhost kernel: ds: 007b   es: 007b   ss: 0068
Apr 11 21:17:11 localhost kernel: Process modprobe (pid: 1653,
threadinfo=17f6f000 task=17f5cc50)
Apr 11 21:17:11 localhost kernel: Stack: 21fde880 17dba9cc 17dba000
17dba000 17dba000 17f6f000 228a6092 17dba000
Apr 11 21:17:11 localhost kernel:        228a07d6 17dba000 229cb80e
17dba000 03467000 229d00fe 03467000 229d2e04
Apr 11 21:17:11 localhost kernel:        229d2e04 021d2582 03467044
0221fb80 229d2e04 229d2e68 0221fba2 0233b1ec
Apr 11 21:17:11 localhost kernel: Call Trace:
Apr 11 21:17:11 localhost kernel:  [<228a6092>]
ieee80211_proc_remove+0x28/0x34 [wlan]
Apr 11 21:17:11 localhost kernel:  [<228a07d6>]
ieee80211_ifdetach+0x5a/0x7f [wlan]
Apr 11 21:17:11 localhost kernel:  [<229cb80e>] ath_detach+0x48/0x4d
[ath_pci]
Apr 11 21:17:11 localhost kernel:  [<229d00fe>]
ath_pci_remove+0x15/0x68 [ath_pci]
Apr 11 21:17:11 localhost kernel:  [<021d2582>]
pci_device_remove+0x16/0x28
Apr 11 21:17:11 localhost kernel:  [<0221fb80>]
device_release_driver+0x3c/0x46
Apr 11 21:17:11 localhost kernel:  [<0221fba2>] driver_detach+0x18/0x26
Apr 11 21:17:11 localhost kernel:  [<0221fd71>]
bus_remove_driver+0x37/0x64
Apr 11 21:17:11 localhost kernel:  [<02220043>] driver_unregister+0xc/0x2a
Apr 11 21:17:11 localhost kernel:  [<021d26de>]
pci_unregister_driver+0xb/0x13
Apr 11 21:17:11 localhost kernel:  [<229d01c7>] exit_ath_pci+0xf/0x22
[ath_pci]
Apr 11 21:17:11 localhost kernel:  [<02134cb9>]
sys_delete_module+0x122/0x162
Apr 11 21:17:11 localhost kernel:  [<0212581c>] ptrace_notify+0x109/0x1ab
Apr 11 21:17:11 localhost kernel:
Apr 11 21:17:11 localhost kernel: Code: 0f 0b 94 02 d2 d6 2f 02 8b 47
40 85 c0 75 09 89 f8 e8 0d ff


This will happen from the command line as well as at boot time.

Version-Release number of selected component (if applicable):
kudzu-1.1.54-1

How reproducible:
Always

Steps to Reproduce:
1.Install an Atheros chipset based wireless 802.11g PCI card
2.Install the madwifi drivers
3.configure /etc/modprobe.conf to:  alias eth0 ath_pci
4.configure /etc/sysconfig/network-scripts/ifcfg-eth0
5.reboot the system
    

Actual Results:  System hangs while kudzu attempts to detect new hardware

Expected Results:  System should boot normally.

Additional info:

Kudzu appears to be using /usr/share/hwdata/pcitable for the pci ids.

I updated this file from a newer pci.ids file, as kudzu was writing
unknown information into /etc/sysconfig/hwconf.
Comment 1 Sean Bruno 2004-04-12 12:56:57 EDT
Created attachment 99330 [details]
strace -f of kudzu at system boot

The most important entry is the last line.  It looks like it tries to delete
the ath_pci module and then it dies.
Comment 2 Bill Nottingham 2004-04-13 00:12:18 EDT
This is a bug in the ath_pci module's /proc handling.

Note You need to log in before you can comment on or make changes to this bug.