Bug 120649 - login w/o network fails because of liblaus dependency
login w/o network fails because of liblaus dependency
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: laus (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Grubb
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-12 13:32 EDT by Eric Hagberg
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 15:55:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Hagberg 2004-04-12 13:32:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040310 Firefox/0.8

Description of problem:
Due to /usr being mounted over the network, logins will fail if the
network is down for some reason, because pam is now pulling in liblaus:

$ ldd /lib/libpam.so.0
        libc.so.6 => /lib/tls/libc.so.6 (0xf64a9000)
        libdl.so.2 => /lib/libdl.so.2 (0xf64a6000)
        liblaus.so.1 => /usr/lib/liblaus.so.1 (0xf64a3000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0xaa000000)

Either liblaus should be moved to /lib or pam shouldn't do this.

Version-Release number of selected component (if applicable):
laus-0.1-48RHEL3

How reproducible:
Always

Steps to Reproduce:
1. install RHEL3 U2 beta
2. set things up so that /usr is mounted over the network
3. pull network cord
4. attempt root login (which normally shouldn't require net access)
5. watch it fail
    

Additional info:
Comment 1 Charlie Bennett 2004-04-12 18:02:30 EDT
laus-0.1-RHEL51 places all of the laus libraries in /lib
Comment 2 David Lawrence 2006-07-17 23:57:37 EDT
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.