Bug 120652 - invalid viewport change requests from libwnck
Summary: invalid viewport change requests from libwnck
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libwnck (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
: 109623 109624 125543 126535 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-12 18:01 UTC by Michal Jaegermann
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 2.6.0.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 06:51:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rediffed patch from 122086 at bugzilla.gnome.org (1.81 KB, patch)
2004-04-12 18:03 UTC, Michal Jaegermann
no flags Details | Diff
actual patch committed upstream (7.66 KB, patch)
2004-07-27 08:22 UTC, Mark McLoughlin
no flags Details | Diff
actual patch committed upstream (really) (2.43 KB, patch)
2004-07-27 08:32 UTC, Mark McLoughlin
no flags Details | Diff

Description Michal Jaegermann 2004-04-12 18:01:19 UTC
Description of problem:

A bug discussed quite extensively at:
http://bugzilla.gnome.org/show_bug.cgi?id=122086
is still present.  It does not affect metacity, which likely
ignores those messages, but other window managers conforming
to EWMH standard are messed up.

A patch referenced in the quoted discussion, i.e.
http://bugzilla.gnome.org/attachment.cgi?id=21124&action=view
still applies and resolves the issue.

For a convenience attached is the same patch rediffed against
libwnck-2.6.0.1 sources but the only change is in diff headers.

Version-Release number of selected component (if applicable):
libwnck-2.6.0.1-1

How reproducible:
100%

Steps to Reproduce:
1. Put into ~/.sawish/rc a line like
   (set-number-of-workspaces 4)
2. Start sawfish; if running metacity wm you can do that by
   typing in a terminal window

    killall metacity && sawfish &

3. Make sure that you have some windows open in some workspaces
   and start mousing around in "Workspace Switcher" on a gnome-panel. 
   You will be screwed in no time at all.  Getting a window
   totally outside of display bounds, so it cannot be even
   "Alt-dragged" into a position, is really easy.

Comment 1 Michal Jaegermann 2004-04-12 18:03:15 UTC
Created attachment 99336 [details]
Rediffed patch from 122086 at bugzilla.gnome.org

Comment 2 Michal Jaegermann 2004-04-12 18:10:21 UTC
Oops, a "require" should be in ~/.sawish/rc so a minimal content
of this file for "Steps to Reproduce" would be:

(require 'sawmill-defaults)
(set-number-of-workspaces 4)


Comment 3 Mark McLoughlin 2004-04-14 14:54:28 UTC
I've just committed the patch upstream, we'll get it when we pull in
the 2.6.1 tarballs:

Upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=122086

Comment 4 Mark McLoughlin 2004-07-27 08:15:10 UTC
I shouldn't really have close this as UPSTREAM - its a bad enough bug
that it warrants getting an FC2 update out for it rather than just
fixing for FC3

Comment 5 Mark McLoughlin 2004-07-27 08:15:32 UTC
*** Bug 126535 has been marked as a duplicate of this bug. ***

Comment 6 Mark McLoughlin 2004-07-27 08:16:53 UTC
*** Bug 125543 has been marked as a duplicate of this bug. ***

Comment 7 Mark McLoughlin 2004-07-27 08:22:56 UTC
Created attachment 102215 [details]
actual patch committed upstream

Comment 8 Mark McLoughlin 2004-07-27 08:26:13 UTC
*** Bug 109624 has been marked as a duplicate of this bug. ***

Comment 9 Mark McLoughlin 2004-07-27 08:26:22 UTC
*** Bug 109623 has been marked as a duplicate of this bug. ***

Comment 10 Mark McLoughlin 2004-07-27 08:28:06 UTC
kas: bug #109623, bug #109624 and bug #125543 all look like the same
issue to me - feel free to correct me if I'm wrong

Comment 11 Mark McLoughlin 2004-07-27 08:32:40 UTC
Created attachment 102216 [details]
actual patch committed upstream (really)

Comment 12 Mark McLoughlin 2004-07-28 06:51:34 UTC
libwnck-2.6.0.1-3 has been pushed to FC2 updates with the fix. A mail
should hit fedora-announce-list soon with the details.

This update can be downloaded from:
  http://download.fedora.redhat.com/pub/fedora/linux/core/updates/2/

Oh, and 2.6.0.1-4 in rawhide has the fix too.


Note You need to log in before you can comment on or make changes to this bug.