Bug 120660 - cryptoloop: losetup and mount do not work with 2.6 crypto API
Summary: cryptoloop: losetup and mount do not work with 2.6 crypto API
Status: CLOSED DUPLICATE of bug 124128
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-12 19:10 UTC by Stephan
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-21 19:02:33 UTC


Attachments (Terms of Use)

Description Stephan 2004-04-12 19:10:23 UTC
Description of problem:

losetup -e aes /dev/loop0 /dev/hdxx 
fails with 
INVALID ARGUMENT

Additional Info:

the Cryptoloop-HOWTO says that there are two patches needed. 
http://www.tldp.org/HOWTO/Cryptoloop-HOWTO/userspace-tools.html

Comment 1 Stefano Bagnara 2004-04-14 17:59:19 UTC
this work for me.
Try "modprobe cryptoloop" and "modprobe aes" first.

I'm using test2 with default (not up2dated) packages (kernel
2.6.3-2.1.253.2.1smp )

Stefano

Comment 2 Elliot Lee 2004-05-13 19:29:36 UTC
This is a dupe of a bug I can't remember right now.

Comment 3 Hermann Schichl 2004-05-21 22:26:40 UTC
I have an SRPM file (for Fedora Core 2) containing the proper patches.
However, I cannot upload it due to size limitations on attachments. If
somebody wants to get it, please send mail.

Comment 4 Elliot Lee 2004-05-24 19:01:28 UTC
Please upload the patches themselves to bugzilla.

*** This bug has been marked as a duplicate of 124128 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:02:33 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.