Bug 120695 - postfix unable to do openldap lookups
postfix unable to do openldap lookups
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: postfix (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-12 22:33 EDT by kevin reichhart
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 12:02:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description kevin reichhart 2004-04-12 22:33:36 EDT
Description of problem:
Using virtual_maps to forward mail to another address results in 
errors in /var/log/maillog and a hung smtp connection.

Removing virtual_maps results in successful smtp connections.

An install of postfix from tarball results in successful lookups and 
forwarding.

---
Version-Release number of selected component (if applicable):
postfix-2.0.11-4/openldap-servers-2.0.27-11

---
How reproducible:
every time

Steps to Reproduce:
virtual_maps = ldap:forwardonly

forwardonly_server_host = localhost
forwardonly_search_base = dc=blah,dc=edu
forwardonly_query_filter = (mail=%s)
forwardonly_result_attribute = mailforwardingaddress
forwardonly_bind = no
===============
ldap entries contain two pertinant fields: mail (rcpt to: address) 
and mailforwardingaddress (address that mail should actually go to)

---
Actual results:
smtp connection hangs indefinitely and errors are logged

---
Expected results:
email addresses to <mail> is forwarded to <mailforwardingaddress>

---
Additional info:
Apr 12 09:29:47 mx2 postfix/smtpd[13258]: warning: premature end-of-
input on private/rewrite socket while reading input attribute name
Apr 12 09:29:47 mx2 postfix/smtpd[13258]: warning: 
resolve_clnt_query: bad read: Success
Apr 12 09:29:47 mx2 postfix/cleanup[13266]: warning: premature end-of-
input on private/rewrite socket while reading input attribute name
Apr 12 09:29:47 mx2 postfix/cleanup[13266]: warning: rewrite_clnt: 
bad read: Connection reset by peer
Apr 12 09:29:47 mx2 postfix/master[13251]: warning: 
process /usr/libexec/postfix/trivial-rewrite pid 13269 killed by 
signal 11
Apr 12 09:29:47 mx2 postfix/master[13251]: 
warning: /usr/libexec/postfix/trivial-rewrite: bad command startup -- 
throttling
Comment 1 John Dennis 2004-04-13 11:43:42 EDT
There have been a number of bug fixes in postfix, especially with
regards to LDAP since the initial RHEL3 release, these appear in RHEL3
Update 2. This new rpm has been successfully tested with LDAP support.
If you do not have access to U2 you may ftp the rpm from here:

ftp://people.redhat.com/jdennis/postfix-2.0.16-13.RHEL3.i386.rpm

Please let me know if this works for you so I can close this bugzilla.
Comment 2 kevin reichhart 2004-04-13 12:02:12 EDT
This RPM works.  

Note You need to log in before you can comment on or make changes to this bug.