Bug 120706 - wrong dependencies in package
Summary: wrong dependencies in package
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: exim (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-13 10:26 UTC by Grigory Bakunov
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 14:54:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Grigory Bakunov 2004-04-13 10:26:55 UTC
Description of problem:
Current exim package doesn't depend on version of perl package but 
linked with libperl.so and didn't start without appropriate version.

Steps to Reproduce:
1. install with --oldpackage package older than  perl-5.8.3-17
2. try to start exim

Comment 1 Thomas Woerner 2004-04-14 14:54:43 UTC
I am sorry, but this is not supported. And by the way:

rpm -qlp perl-5.8.3-10.1.1.i386.rpm | grep libperl.so
/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE/libperl.so
/usr/lib/perl5/5.8.1/i386-linux-thread-multi/CORE/libperl.so
/usr/lib/perl5/5.8.2/i386-linux-thread-multi/CORE/libperl.so
/usr/lib/perl5/5.8.3/i386-linux-thread-multi/CORE/libperl.so

rpm -qlp perl-5.8.3-13.i386.rpm | grep libperl.so
/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE/libperl.so
/usr/lib/perl5/5.8.1/i386-linux-thread-multi/CORE/libperl.so
/usr/lib/perl5/5.8.2/i386-linux-thread-multi/CORE/libperl.so
/usr/lib/perl5/5.8.3/i386-linux-thread-multi/CORE/libperl.so

These are compatible.


Note You need to log in before you can comment on or make changes to this bug.