Bug 12072 - po/Makefile.in.in does not use DESTDIR
po/Makefile.in.in does not use DESTDIR
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gettext (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-10 20:11 EDT by Sam Varshavchik
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-30 21:20:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to the default po/Makefile.in.in template. (515 bytes, patch)
2000-06-10 20:12 EDT, Sam Varshavchik
no flags Details | Diff
patches mentioned above (4.15 KB, patch)
2000-08-04 15:21 EDT, Enrico Scholz
no flags Details | Diff

  None (edit)
Description Sam Varshavchik 2000-06-10 20:11:14 EDT
I just reported this to GNU.  I'm sure it'll be fixed in whenever the next
release of gettext goes out.

The problem is that the install targets in the default po/Makefile.in.in
template do not use DESTDIR, making it impossible to install anything that
uses the GNU gettext library to install underneath a build root.

Any RPM that uses BuildRoot: for anything that uses gettext is, basically,
broken.

I'm going to attach a small patch to fix this.
Comment 1 Sam Varshavchik 2000-06-10 20:12:09 EDT
Created attachment 399 [details]
Patch to the default po/Makefile.in.in template.
Comment 2 Trond Eivind Glomsrxd 2000-07-10 16:29:25 EDT
Fixed - should show up in next Rawhide. Thanks.
Comment 3 Enrico Scholz 2000-08-04 10:08:32 EDT
Patch seems to be incomplete because `intl/Makefile.in' is involved in the
DESTDIR issue also. 

Additionally please note my comments and patches in message
<m3bt16rlj2.fsf@kosh.ultra.csn.tu-chemnitz.de> (news:gnu.utils.bug) (archived
under http://www.deja.com/[ST_rn=ps]/getdoc.xp?AN=633901487):

| Using DESTDIR in this way is a bad idea because it breaks e.g.  "make
| DESTDIR=/tmp/... datadir=/usr/share install". It's better to use it in
| the install-rules explicitly.
Comment 4 Trond Eivind Glomsrxd 2000-08-04 15:06:32 EDT
Can you attach those patches to this bug? TIA.
Comment 5 Enrico Scholz 2000-08-04 15:21:50 EDT
Created attachment 2034 [details]
patches mentioned above
Comment 6 Trond Eivind Glomsrxd 2000-08-04 15:33:41 EDT
Thanks - applied.
Comment 7 Enrico Scholz 2000-08-30 21:15:55 EDT
Although the patch is in the src.rpm, it won't be applied... Perhaps you have
forgotten `patch6 -p1' in the %setup-stage.
Comment 8 Enrico Scholz 2000-08-30 21:20:24 EDT
Sorry, must be `patch6 -p0'
Comment 9 Trond Eivind Glomsrxd 2000-09-03 19:03:49 EDT
This has since been fixed (before the reopening, actually - when applying other
patches for gettext to make it work better).
Comment 10 Sam Varshavchik 2001-05-03 09:50:33 EDT
Received an acknowledgement from GNU that the original issue has been fixed in
gettext 0.10.37


Note You need to log in before you can comment on or make changes to this bug.