Bug 120724 - use of ifdown script or neat cause kernel panic
use of ifdown script or neat cause kernel panic
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 10:42 EDT by Todd Fisher
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 04:57:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Fisher 2004-04-13 10:42:41 EDT
Description of problem:
If I use ifdown or neat to deactivate my ethernet card my
system locks up.

Version-Release number of selected component (if applicable):
kernel - 2.6.5-1.315
system-config-network - 1.3.16
net-tools - 1.60
ifconfig 1.42 (2001-04-13)

How reproducible:
ifdown eth0 or neat select eth0 and click deactivate
  
Additional info:
also, whenever I issue the command
su -
shutdown -r now or shutdown -h now
i get the following kernel panic:
reproduced here as closely as possible to what I read from the 
crashed machine.

generic_file_aoi_read
do_page_fault
sel_write_user
pte_alloc_one
pte_alloc_map
handle_mm_fault
get_user_pages
str_vm
elf_map
zero_user_size
load_elf_interp
load_elf_binary
avc_has_perm
search_binary_handler
[<0216c697>] do_execve+0x187/0x219
[<02104958>] sys_execve+0x2a/0x6f

kernel/timer.c:295 spin_lock(kernel/timer.c:023313e0) already locked
by kernel/timer.c/392
Kernel panic: Fatal exception in interrupt
In interrupt handler - not syncing
Comment 1 Arjan van de Ven 2004-04-13 10:43:44 EDT
what kind of network card is this ?
(eg which kernel module)
Comment 2 Todd Fisher 2004-04-13 12:20:48 EDT
neat hardware tab:

82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller
Prism 2.5 Wavelan chipset
orinoco_pci

from /etc/sysconfig/hwconf

class: NETWORK
bus: PCI
detached: 0
device: eth
driver: e100
desc: "Intel Corp.|82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller"
vendorId: 8086
deviceId: 1031
subVendorId: 1014
subDeviceId: 0209
pciType: 1

and the wireless card:

class: OTHER
bus: PCI
detached: 0
driver: orinoco_pci
desc: "Harris Semiconductor|Prism 2.5 Wavelan chipset"
vendorId: 1260
deviceId: 3873
subVendorId: 1668
subDeviceId: 0406
pciType: 1

My system was originally a redhat 9 machine.  I used apt to upgrade it
to fc1 and then downloaded the fc2-test2 iso used the installer to
upgrade to fc2-test2 and have since switched to yum downloading all
the updates todate.
Comment 3 Todd Fisher 2004-04-13 13:43:03 EDT
looks like the problem was fixed in the change to 2.6.5-1.319
ifdown doesn't lock up the system and shutdown -r doesn't cause
a kernel panic anymore.
Comment 4 Arjan van de Ven 2004-04-16 04:57:07 EDT
hmmmmm ok I'll close it then.
If it comes back please reopen..

Note You need to log in before you can comment on or make changes to this bug.