This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 120732 - LTC7527-DHCP Client doesn't receive address from DHCP server
LTC7527-DHCP Client doesn't receive address from DHCP server
Status: CLOSED DUPLICATE of bug 111540
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: dhcp (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 12:11 EDT by Helen Fischer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Helen Fischer 2004-04-13 12:11:28 EDT
The following has be reported by IBM LTC:  
DHCP Client doesn't receive address from DHCP server
Hardware Environment:
IBM z/990
OSA Express in QDIO mode


Software Environment:
z/VM 4.4
Linux guest running 2.4.21-11.EL or 2.4.21-12.EL (64 bit)
OSA entry in /etc/chandev.conf specifies fake_ll option
dhclient-3.0pl2-6.14
dhcp-3.0pl2-6.14

Steps to Reproduce:
1. Have a DHCP server running on either intel box or s/390 Linux 
system
2. From client issue : dhclient ethx (x is the interface)
3.

Actual Results:
DHCP client times out without receiving IP address from server

Expected Results:
DHCP client would receive DHCP address.

Additional Information:

I believe in order for this scenario to work, the client has to be 
able to 
request that the server broadcast it's response back to the client.  
I do not 
see a way to pass such a request with dhclient.
Comment 1 Bob Johnson 2004-05-12 11:18:19 EDT
broadcast on internal network not possible ?
Comment 4 Jason Vas Dias 2004-08-04 18:22:03 EDT

*** This bug has been marked as a duplicate of 111540 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:02:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.